Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,018
    +1
    304

    I found my oil leak

    Was losing only a minuscule amount, but I like to account for every drop...

    It was a brand new O ring, too. I prob. didn't have it snugged all the way up when I screwed the filter lid back on.

    (Note to self: Don't do maintenance while under the influence...)

    If anybody has got a spare, I'm in the market. It's the smaller diameter ring that goes near the top (06 RXT). I haven't checked, but I'm guessing the shipping will far out-weigh the cost of ordering a new one.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P1140290.jpg 
Views:	78 
Size:	100.4 KB 
ID:	233867  


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    That is just a dust seal the main seal in around the lower part if the cap Ive been running without it for years.

  3. #3
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,018
    +1
    304
    I thought the same thing, but I've been having a small amount of oil on the bolt head. And the bottom, larger O ring is in good shape. Maybe I should check the little black O ring on the shaft...

  4. #4
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    Pm me an address. I'll put one in the mail tomm.

  5. #5
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Quote Originally Posted by 83Gator View Post
    I thought the same thing, but I've been having a small amount of oil on the bolt head. And the bottom, larger O ring is in good shape. Maybe I should check the little black O ring on the shaft...
    Have a look there..Had the same issue on two different skis. I just replaced the cap and all. That hole opens up a little every time you pull it off for a filter change..From memory it was less than $15 to replace everything (less bolt).

  6. #6
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    Do you have a metal or plastic oil filter cap?

  7. #7
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,018
    +1
    304
    Quote Originally Posted by mrbtd View Post
    Have a look there..Had the same issue on two different skis. I just replaced the cap and all. That hole opens up a little every time you pull it off for a filter change..From memory it was less than $15 to replace everything (less bolt).
    I will monitor that situation... thanks for the tip.

    Quote Originally Posted by Joe Stang View Post
    Do you have a metal or plastic oil filter cap?
    It is the one made of metal; PM sent. Thanks,

  8. #8
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    +1
    1
    I've fixed two leaks recently because of a bad O ring under the bolt head in the cap. The one O ring wasnt even torn all the way but enough to spray oil on the head and coolant hose. If its pooling around the bolt head thats what my money is on.

  9. #9
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,018
    +1
    304
    Quote Originally Posted by 01xdime View Post
    I've fixed two leaks recently because of a bad O ring under the bolt head in the cap. The one O ring wasnt even torn all the way but enough to spray oil on the head and coolant hose. If its pooling around the bolt head thats what my money is on.
    You can bet I will be looking at it tonight...

  10. #10
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Also starting in 09 the bolt is captive and will jack the cap off when you remove the center bolt.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Found my boost leak..
    By Gsmith88 in forum Kawasaki How To & FAQs
    Replies: 79
    Last Post: 04-01-2016, 09:08 AM
  2. found my leaking carb plus like a dummy, I stripped out my carb bolt
    By jasonmd13 in forum Polaris Tech Tips and Info
    Replies: 7
    Last Post: 05-15-2013, 08:08 AM
  3. Found a couple metal shavings in my oil screen...
    By TheEngineer in forum 4-Tec Performance
    Replies: 17
    Last Post: 11-13-2012, 10:07 AM
  4. Oil leak I think I found thought I would share
    By race24x in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-31-2011, 07:15 PM
  5. FOUND MY *%^$#! Leak!!
    By Pistonwash in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 02-18-2006, 11:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •