Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1

    Join Date
    Mar 2011
    Location
    Dalton, GA
    Posts
    12

    Need some advice 2007 Ultra 250X

    Bought a deal I couldn't refuse on a 2007 250x with only 16 hrs. still under warranty. But took it to the lake and it tops out around 55-56 speedometer and GPS. Turning 7700-7800 rpms, didn't pay attention to the boost, but according to other posts the rpms are good. Looked in the pump no debris or noticable damage to the impeller. Any suggestions?


  2. #2
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    Quote Originally Posted by adawgfan View Post
    Bought a deal I couldn't refuse on a 2007 250x with only 16 hrs. still under warranty. But took it to the lake and it tops out around 55-56 speedometer and GPS. Turning 7700-7800 rpms, didn't pay attention to the boost, but according to other posts the rpms are good. Looked in the pump no debris or noticable damage to the impeller. Any suggestions?
    the prop pitch could have been change, ask the the owner you bought it from if they change the prop pitch

  3. #3

    Join Date
    Mar 2011
    Location
    Dalton, GA
    Posts
    12
    Quote Originally Posted by brisyl View Post
    the prop pitch could have been change, ask the the owner you bought it from if they change the prop pitch
    A good thought but the lady I bought it from was in her mid 50's and didn't seem the type to mod her PWC. I am beginning to suspect she or her sons ran it on a sand bar and ground out the pump. Does anyone know what the spacing should be between the impeller and the pump walls? It was used in Lake Blackshear which I hear is kind of shallow.

  4. #4
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    Quote Originally Posted by adawgfan View Post
    A good thought but the lady I bought it from was in her mid 50's and didn't seem the type to mod her PWC. I am beginning to suspect she or her sons ran it on a sand bar and ground out the pump. Does anyone know what the spacing should be between the impeller and the pump walls? It was used in Lake Blackshear which I hear is kind of shallow.
    Impeller Clearance
    Standard: 0.15 ∼ 0.3 mm (0.0059 ∼ 0.0118 in.)
    Service Limit: 0.6 mm (0.0236 in.)

  5. #5
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    a tip, if you can see a gap it needs repairing, anything above .15 and they will cavitate, but that shouldnt effect top end speed.

  6. #6

    Join Date
    Mar 2011
    Location
    Dalton, GA
    Posts
    12
    @ brisyl and nicjak, Thank you both. I can see a gap looks to be at least 1/32 just by visual inspection. I'll check the gap on it this weekend. If this is the problem, what parts do you recommend? Why do you think it would not affect top end? I've had many PWCs but this is my first Ultra 250, most I've ever ridden especially my old Ultra 150 and RXT 215 had a steady take off, however this one seems to almost rev slightly or cavitate slightly (.5 sec or less on quick take off) from idle to 2000 rpms before it hooks up. From there to top speed (56) it has great throttle response. Didn't know if this was normal or not?

  7. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    proper clearance it shouldnt cavitate on take off ive just rebuilt mine which had .3 clearance now it is back to .1 and it was cavitating only on wot take offs. no cavitation after that

  8. #8

    Join Date
    Mar 2011
    Location
    Dalton, GA
    Posts
    12
    Thanks for your help. I'm no mechanic, but thinking the prob must be in the pump if I'm getting the rpms. Do you recommend Kawi or Solas impeller for replacement?

  9. #9
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    Quote Originally Posted by adawgfan View Post
    Thanks for your help. I'm no mechanic, but thinking the prob must be in the pump if I'm getting the rpms. Do you recommend Kawi or Solas impeller for replacement?
    if your stock to lightly mod go with the stock kawi,it the best overall for lightly mod Ultra

  10. #10
    MADRUI madrui's Avatar
    Join Date
    Oct 2008
    Location
    portugal-algarve
    Posts
    125
    adawgfan i had that problem and was because i hit some rocks and the impeller stayed weed the blads a litle out off alligment and that has my problem.it made the same like yourse.good luck

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some advice on 1999 Ultra 150
    By RichardS in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 03-31-2016, 09:53 AM
  2. Needing Performance parts for 2007 Ultra 250x
    By Srt475 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 10-31-2012, 02:43 PM
  3. Need some advice on an Ultra 150
    By jonw in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-16-2011, 10:33 PM
  4. Need some advice on possibly picking up an Ultra 150...
    By 03stage2 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 04-19-2010, 07:49 AM
  5. Just bought an 06 RXP, need some advice!
    By NeverEndn in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-11-2006, 12:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •