Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    1996 SLT 780 engine won't turn over

    Getting ready for the season, new battery, steering cable, and a fresh tank of gas but she won't turn over. Tries too but but something seems to be seized. Can't believe it's anything with the motor, it's only got 13 hrs on it since replacement. She ran like a champ last time I used it last season. I don't know how to diagnose the problem, any suggestions???


  2. #2

    1996 SLT 780 engine won't turn over

    Getting ready for the season, new battery, steering cable, and a fresh tank of gas but she won't turn over. Tries too but but something seems to be seized. Can't believe it's anything with the motor, it's only got 13 hrs on it since replacement. She ran like a champ last time I used it last season. I don't know how to diagnose the problem, any suggestions???

  3. #3

    1996 SLT 780 engine won't turn over

    Getting ready for the season, new battery, steering cable, and a fresh tank of gas but she won't turn over. Tries too but but something seems to be seized. Can't believe it's anything with the motor, it's only got 13 hrs on it since replacement. She ran like a champ last time I used it last season. I don't know how to diagnose the problem, any suggestions???

  4. #4

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    remove the pump and see if it turns

  5. #5
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,139
    +1
    1,050
    I've combined your three posts. Typically, posting in one spot and waiting a bit for a response works better. It keeps it from getting confusing.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Won't turn over, as in the starter motor doesn't crank the engine - correct?

    You hear the starter motor engage, but the engine doesn't budge?

    Remove the jet pump and drive shaft. If it still won't crank, see if you can turn the engine over by hand using the PTO coupler. Take the spark plugs out to eliminate compression resistance.

    Was the engine running properly for you last year just before it got put away?

    Was the engine fogged and winterized before storage?

  7. #7
    Correct, starter engages but motor doesn't budge. Worked great last time I used it, and no, I didn't winterize. Usually I do but not last year.

    I'll remove the jet pump and drive shaft and see what happens. Thanks!

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Remove the spark plugs and see if it turns over.

    If not, take a peek down the plug holes with a small flashlight and look for rust on the cyls.

    If no rust, remove the driveshaft and try again.

    I'm afraid your rings are rusted to the cyls if you didn't fog/winterize the engine.

  9. #9
    I'll give it a try. Thanks!

  10. #10
    I removed the plugs, looked down the cylinders and they are clean, very clean. I squirted WD40 in the cylinders for a couple of days and tried again with plugs removed. Looks like I'll have to pull the drive shaft afterall. I haven't done this before, will I need any spare parts like seals or gaskets???

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1100 ZXi Engine won't turn over when plugs are installed??? Help
    By jkv1216 in forum Kawasaki Open Discussion
    Replies: 36
    Last Post: 04-08-2015, 05:07 PM
  2. Help... Engine won't turn over
    By frostymugs in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-07-2011, 08:35 AM
  3. engine won't turn over
    By freelancenovelist in forum MSX/Matrix
    Replies: 4
    Last Post: 06-19-2009, 05:39 PM
  4. 1996 SLT 780 Turns Over But Does Not Run
    By gchanspike in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 06-22-2008, 04:57 PM
  5. HELP PLEASE! 96' SLT 780 won't turn over
    By cnicholas in forum Polaris How To & FAQs
    Replies: 25
    Last Post: 06-20-2008, 10:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •