Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3

    just tested my 07 250x, somethings not right

    its got 50hrs, the ski starts and sounds good. just wanted to see what i should look and listen for before i start getting on it.

    i already ordered up the shaft, seals, bearings, nut, etc for the 300x to replace. i am not going to be riding the ski hard today just want to test it out so i know if i need to do something else to it or not before summer.

    the ski is stupid fast, but somethings not right, hole shot is terrible just bounces of rev limiter, my cousins 07 rxt 215hp takes off and leads by a few length, mid range is similar, top end he crawls away. rpms are 8000 wot, 64.9 mph on my fastest droid app, and between 10 and 11 lbs boost on gage. anyhting under 25mph when i floor it it just pops off the rev limiter.


  2. #2
    UltraKvz's Avatar
    Join Date
    Feb 2011
    Location
    Earth
    Posts
    378
    +1
    23
    Be on the lookout for sharks..............

    Quote Originally Posted by 98gsxl951 View Post
    its got 50hrs, the ski starts and sounds good. just wanted to see what i should look and listen for before i start getting on it.

    i already ordered up the shaft, seals, bearings, nut, etc for the 300x to replace. i am not going to be riding the ski hard today just want to test it out so i know if i need to do something else to it or not before summer.

  3. #3
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3
    the ski is stupid fast, but somethings not right, hole shot is terrible just bounces of rev limiter, my cousins 07 rxt 215hp takes off and leads by a few length, mid range is similar, top end he crawls away. rpms are 8000 wot, 64.9 mph on my fastest droid app, and between 10 and 11 lbs boost on gage. anyhting under 25mph when i floor it it just pops off the rev limiter.

  4. #4
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    Quote Originally Posted by 98gsxl951 View Post
    the ski is stupid fast, but somethings not right, hole shot is terrible just bounces of rev limiter, my cousins 07 rxt 215hp takes off and leads by a few length, mid range is similar, top end he crawls away. rpms are 8000 wot, 64.9 mph on my fastest droid app, and between 10 and 11 lbs boost on gage. anyhting under 25mph when i floor it it just pops off the rev limiter.
    Prop to pump clearence is to big,check clearence,if you have more then 0.15mm it will cavitate and You are due for a new prop

  5. #5
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3
    could it be a wear ring?

  6. #6
    hilomikey's Avatar
    Join Date
    Apr 2007
    Location
    Hilo Hawaii
    Posts
    482
    This may sound funny but what key are you using? The yellow or orange.

  7. #7
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3
    orange. yellow is the the SLO one correct

  8. #8
    hilomikey's Avatar
    Join Date
    Apr 2007
    Location
    Hilo Hawaii
    Posts
    482
    correct,

  9. #9
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    Quote Originally Posted by 98gsxl951 View Post
    could it be a wear ring?
    there is no wear ring on a Ultra, but normally it's the impeller that wear first, but you need to check the pump housing too when you remove the impeller

  10. #10
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3
    how much is a good used stock prop go for usually?

    if i shine down with a flash light will i be able to see if the pump or impellar is out of whack or what not. ?

    could it be my pump bearing that is failing and causing excess wear?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. a few questions i have that searching and reading did not answer on my 07 250x.
    By 98gsxl951 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 04-09-2011, 11:30 AM
  2. Just testing my new avatar
    By NJJer in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 02-04-2010, 11:30 PM
  3. Replies: 5
    Last Post: 03-22-2009, 08:53 PM
  4. just tested my vf3 reeds from fernando
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 05-18-2006, 08:52 AM
  5. I just tested my stock ECU with the 15/20
    By Green Hulk in forum 4-Tec Performance
    Replies: 15
    Last Post: 08-22-2005, 03:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •