Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1

    Join Date
    May 2009
    Location
    Broadstairs, Kent, England
    Posts
    138
    +1
    2

    '04 RXP cutting out + sensor displayed and no VTS indicator

    Hi, took my RXP out onto the Ocean for the first time of the season yesterday but I had some problems. I'm annoyed as most winters my ski is left outside with a cover on, but this year I stored it in a dry lock-up with the battery removed.

    After searching the forum it looks like the sensor indicator and no VTS display is a "simple" problem caused due to the ski losing it's memory as the battery was removed for a long period, it needs re-setting on BUDS. Please correct me if I'm wrong.

    Now to the cutting out. When I first put the ski on the water I had to wiggle the DESS cap a few times to get the ski to display "Welcome" etc, it then started fine. As it was first use of the year I ran slowly for a few minutes, only using small amounts of throttle - everything was fine (apart from the sensor display and no VTS display). But when I opened the throttle some more the ski cut out completely (no beeping or anything on the display, and no beeping to suggest the DESS key was still in). When I removed the DESS key and re-attached it the ski would start again. I did cut out a few more times whilst I was trying to accelerate more, but eventually I was able to do full throttle running. But sometimes mid a full throttle run it would completely die again.

    I've read it might be a mad earth but I've checked the battery posts and they are screwed on securely. Can anyone offer advice on what the problem might be? I'm guess the DESS fob might be the problem but the contacts look clean on both the ski part and the lanyard.

    Oh, and while it was running it was running fine, great to be out again and blow those winter cobwebs away (but the sea was only 9C / 48 F).

    Thanks... Adrian


  2. #2
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24
    Bad gas? Plugs? Or injectors? Mine is doing the same. I'm thinking the computer reset may help too

  3. #3
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24
    If u still have ceramic washers. That's also a sign of SC failure

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    It's an electrical issue. Mine had the same problem a week ago.
    Check your pos. And neg. Cables to the block, and mostly at the battery, and start selonoid
    For corrosion. Then get it hooked to buds to clear codes, and activate VTS.

  5. #5
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    Hook it up to BUDS, clear codes, and whatnot. Also have them reset TPS.

    Fill with fresh gas, change spark plugs. If you properly winterized, the fogging oil might have fouled plugs - it happens.

  6. #6

    Join Date
    May 2009
    Location
    Broadstairs, Kent, England
    Posts
    138
    +1
    2
    Thanks, it was winterised but I don't think it can be the plugs, surely they wouldn't all go at once. I think it must be electrical, given the display cuts out completely. I'll check the starter solenoid too.

    Cheers.

  7. #7
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24
    Couldn't hurt to change the plugs man. 15 bucks. That was my issue. Fogin the engine fowled em out.

  8. #8
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24
    Also me know what ur dealer says. I called one that told me the vts had nothin to do with the computer. I'll prolly just buy candoo... It's just $$$ to do so

  9. #9
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by alex_baker202 View Post
    Also me know what ur dealer says. I called one that told me the vts had nothin to do with the computer. I'll prolly just buy candoo... It's just $$$ to do so

    Call someone else... cause their wrong if the trim indicator isn't displayed on the dash You could put a brand new VTS module in it... and it still won't work!

  10. #10

    Join Date
    May 2009
    Location
    Broadstairs, Kent, England
    Posts
    138
    +1
    2
    Anyone have any tips about getting to the starter solenoid (it's right underneath the exhaust manifold right)? I now remember last year it wouldn't start sometimes, but when I wiggled the cable going to the solenoid it started, but I remember it being a right b*tch just to get my hand to it, not sure how I would remove the cable to clean it up without taking the exhaust manifold off (hassle).

    I will try the plugs too.

    A.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. rxp beeping after key removed and no vts dispay or operation
    By Mike in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-21-2017, 08:38 PM
  2. FS 04 rxp part out
    By pimpdaddy1787 in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 08-29-2010, 05:43 PM
  3. RXP cutting out question.
    By skyman707 in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-12-2010, 07:05 PM
  4. 99 GTX Limited with dim display and no Beeps
    By JohnCiccarelli in forum 2-Stroke Performance
    Replies: 10
    Last Post: 05-21-2010, 11:38 PM
  5. 2006 RXP cutting out.
    By Kahnvex in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-03-2007, 12:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •