Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    gpr 1200 yamaha speedometer not working

    Anybody got any suggestions why my speedometer not working? Tach, fuel gauge, etc. work but speedometer read "0" for mph. It happened while running it in ocean banging some waves. Thinking maybe a wire came loose but don't see it.


  2. #2
    check the speedo sensor that is bolted in the ride plate on the left side of the jet pump. maybe the wheel is broken, jambed. if it spins freely, you have to check the output of the sensor., and/or look for any break in the wire all the way from the sensor to the plug up front by the bucket.

  3. #3
    sensor spins freely. wire is intact all the way up. It is plugged in securely. How would I check output of sensor?

  4. #4
    Speedometer display
    1. Check:
    • Speedometer display
    Does not display → Measure the speed
    sensor output voltage and pulses.
    2. Measure:
    • Speed sensor output voltage and pulses
    Out of specification → Replace the
    speed sensor.
    Within specification → Replace the multifunction
    meter


    Speedometer display
    1. Check:
    • Speedometer display
    Does not display → Measure the speed
    sensor output voltage and pulses.
    2. Measure:
    • Speed sensor output voltage and pulses
    Out of specification → Replace the
    speed sensor.
    Within specification → Replace the multifunction
    meter.
    Speed sensor output voltage
    (dependant on the paddle wheel
    position):
    Less than 400 mV
    More than 11.6 V
    Output pulse:
    2 pulses/1 full turn
    Measurement steps:
    • Connect a 12 volt battery to the white
    three-pin connector (between the red/yellow........Battery+ to the R/Y wire
    and black/yellow leads).....................................Battery - to the B/Y wire
    • Rotate the paddle wheel by hand and
    measure the voltage between the yellow.........connect DC voltmeter + to Y wire
    and black/yellow leads..................................connect DC voltmeter - to B/Y wire
    NOTE:
    As the paddle wheel is rotated, a squarewave
    voltage signal a is produced.
    • Two pulses occur every time the paddle
    wheel makes one full turn.


    I can not copy the diagram. this is right out of the service manual, hope this helps...

  5. #5
    KamikazeGPR's Avatar
    Join Date
    Mar 2007
    Location
    Philadelphia
    Posts
    1,361
    +1
    99
    [QUOTE=I can not copy the diagram. this is right out of the service manual, hope this helps...[/QUOTE]

    pictures
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	bvvb.jpg 
Views:	875 
Size:	57.8 KB 
ID:	234768  

  6. #6
    Quote Originally Posted by KamikazeGPR View Post
    pictures
    excellent Tony, Thanks ... I couldn`t get`er done...

  7. #7
    Thank you both. Busy wk but will get to it this wknd. Let u no what happens. Thanks again.

  8. #8

    Join Date
    May 2007
    Location
    Chicago
    Posts
    25
    Were you able to figure out if you had a bad sensor? I'm debating buying the equipment to test it or just buy a new sensor and save some time. Mine did the exact same thing, it was forking fine one minute and quite working the next.

  9. #9
    Banned User
    Join Date
    Feb 2017
    Posts
    8
    I have a 2001 Gp1200R ski and the cluster got water in it, is there a repair to it and if not what other cluster can I use or does it have to be a specific cluster for it?

  10. #10
    African-American
    Join Date
    Feb 2007
    Location
    Cape Town, South Africa
    Posts
    2,226
    +1
    88
    Cut it open and see if you can repair it.

    Otherwise build a new one, see my signature or buy a replacement.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 XLT 1200 Speedometer not working...
    By tman259 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-28-2016, 11:01 AM
  2. 2001 XLT 1200 speedometer not working
    By cedgmon in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-20-2012, 06:44 AM
  3. MPH/Speedometer Not Working
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-24-2009, 10:25 PM
  4. 1999 genesis ficht speedometer not working
    By wmwbutler in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-04-2007, 12:54 PM
  5. Speedometer Not Working
    By jack in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-25-2005, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •