Results 1 to 8 of 8
  1. #1

    New to the GP world and need some help

    Took the ski out for the first time today.
    When I got it the guy said I would need to get d-plate to stop the warnings. Removed the stinger one night and it looks like it has the plate and the sensor chip already. Going out today the warning light came on with the engine picture flashing. I rode to the beach and stopped for 20 mins. When i got out riding again, everything was looking good. 20 mins later the light came on and then at full throttle the ski would just shut off. What could my problem be?

    Another issue: when flushing it with the hose there is water spurting out of the nut on the #3 cylinder head underneath the stinger? Someone told me maybe need a new head gasket.

    Just want to get everything right for the summer. Also is there anyone in the Baltimore Maryland area that is an expert on working on GP's? Thanks


  2. #2
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Welcome to the Greenhulk forums

    You saying your boat is a GP or GPR?

  3. #3
    philip_gpr's Avatar
    Join Date
    Dec 2005
    Location
    Canada
    Posts
    2,724
    +1
    3
    Another issue: when flushing it with the hose there is water spurting out of the nut on the #3 cylinder head underneath the stinger? Someone told me maybe need a new head gasket


    that's not good, you probably shouldn't ride again until this gets fixed

    so I think the cylinder head needs to come off to inspect things

    actually just to be sure, before you do that you might do a compression test first, then pull the head, inspect for damage and replace cylinder head gasket

    not sure about the warning light, let us know which ski and maybe WFO can help with it

  4. #4
    yeah dude i have some pictures of 1200 engine that compressed water me and my buddy are rebuilding not good def get that fixed cheapest engine we could find was 1600!! i woulnt risk that

  5. #5
    I'd pull the plug wires off all 3 spark plugs and remove the plug form the #3 cylinder and crank it over and see if any water comes out of the spark plug hole. If so I would repeat this process on all 3 cylinders to remove as much water as possible before you do a compression test.

  6. #6
    Its a 2003 GP1300r. Took the head off and checked everything out. no water in there but there is one other thing that is weird. cylinder 2 and 3 are .060 and the #1 cylinder is STD. Why in the world would someone bore out 2 cylinders and not the third? Replaced the head gasket and will take it for a run today and let you guys know what happens. Thanks for your help so far.

  7. #7
    Found out the code 64 YPVS servo motor malfunction. How do you fix that and how much does that cost?

  8. #8
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by brider50 View Post
    Found out the code 64 YPVS servo motor malfunction. How do you fix that and how much does that cost?
    probably a bad servo motor, which is really not that common on a 13R

    also if it has #2 and #3 at .060 over, then you have SBT sleeved cylinders, which is not so good... factory has nikasil plated cylinders- aftermarket use steel sleeves and sometimes oversize pistons

    IMO you really need to put the bigger cylinders at #1 and #2. Since its an EFI, you cant adjust fuel mixture for independent cylinders. The #3 is the problem child on 13Rs, and you want less heat on that one. The .060s need more fuel than the std size bore

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to SoCal and Need Some Help
    By NickSezz in forum Open Discussion
    Replies: 5
    Last Post: 08-29-2016, 06:41 AM
  2. Hello, I'm very new to the pwc world and am findin a couple bumps..
    By acer.boy in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-23-2015, 11:53 AM
  3. New to maintenance on myski and need a little advice
    By coyle2285 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-29-2007, 08:40 PM
  4. Hello, I'm new here and need some help....
    By RXP Keith in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-19-2007, 06:47 PM
  5. New to the PWC world...in Northern Illinois
    By Masqua in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 07-28-2005, 06:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •