Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    May 2009
    Location
    Pensacola FL
    Posts
    20

    2007 VX Deluxe check engine light.

    My check engine light and buzzer goes off after the engine has ran just for a few minutes. Any advice on what to check? Just had a full maintenance.


  2. #2
    VinceC's Avatar
    Join Date
    Mar 2011
    Location
    Palmetto, Florida, United States
    Posts
    727
    +1
    56
    My suggestion is take it back to whoever did the maintenance immediately. They can plug in and diagnoseto determine the problem AND take responsibility for not doing their job. Be skeptical of whatever their excuse might be and double check that they did the work that they billed you for.

    If you did the maintenance yourself then of course this bet is off and you need to be more careful learning.

  3. #3

    Join Date
    May 2009
    Location
    Pensacola FL
    Posts
    20
    The maintenance was done by a shop, but it had done this right before I took it in. It was time for the maintenance to be done so I figured once that was taken care of it would possibly stop, so I didn't even mention it to the shop. They did what they were supposed to do but it didn't fix the check engine light from coming on after a few minutes of it running.

  4. #4
    Neighborhood Superman SlowStang305's Avatar
    Join Date
    Jun 2008
    Location
    FL
    Posts
    1,324
    +1
    7
    Sounds like something may have come unplugged or a clogged cooling line. Are you pissing water out of the side while on the hose?

  5. #5

    Join Date
    May 2009
    Location
    Pensacola FL
    Posts
    20
    Yeah that's the weird thing, the wager still comes out like normal..doesn't seem any more warm then usual either.

  6. #6

    Join Date
    May 2009
    Location
    Pensacola FL
    Posts
    20
    Wager = water in my last comment

  7. #7

    Join Date
    May 2009
    Location
    Pensacola FL
    Posts
    20
    Ok, well after talking to the shop that services my ski they told me that they can't help me with the issue because only Yamaha dealers have access to the software that is required to get the codes. The 2 yamaha dealers that are driving distance from me has a turn around time of at least 1 week all the way up to 2 weeks. I'm really wanting to get this done by next week. Anybody know of anyone in the Pensacola FL area that could get this done sooner? I've already checked Pensacola Motorsport's and Halls Motorsport's..

  8. #8
    There are members on here with the software, u might have to drive and buy beer though.

  9. #9
    GP1800's Avatar
    Join Date
    Oct 2007
    Location
    Cassville
    Posts
    166
    You can pull the codes through the gauges.

  10. #10

    Join Date
    May 2009
    Location
    Pensacola FL
    Posts
    20
    I'm willing to do both.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. check engine light on a gp 1300 2007
    By rolo2230 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-30-2009, 02:05 PM
  2. Check engine light
    By mooneyb91084 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-20-2007, 12:26 PM
  3. Check engine light! Not pulling a code... HELP!!
    By Venator in forum 4-Tec Performance
    Replies: 10
    Last Post: 12-10-2006, 07:58 PM
  4. check engine light came on when i went down to sea level
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2005, 02:00 PM
  5. Check Engine Light
    By meeper in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-27-2005, 04:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •