Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3

    valve cover leaking

    Any suggestions on how to fix this? My oring looks to be good, but obviously I am leaking oil. I just got the ski back together, fired it up, and kept hearing a fizzle sound by the exhaust manifold. I thought I had a water leak, but once I ran my hand around the side I noticed it was oil. I kept wondering why everytime I would put oil in it it would drain out.
    I figure a new one will do the trick just trying to see if there is a quick fix to test this ski out. Halomar?
    SHOOTER


  2. #2
    BLACK MAGIC HEADERS hydrojunkie's Avatar
    Join Date
    Jun 2007
    Location
    new york
    Posts
    3,529
    +1
    3
    new gasket and valve cover. i have both if you need

  3. #3
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by shooter98xpl View Post
    Any suggestions on how to fix this? My oring looks to be good, but obviously I am leaking oil. I just got the ski back together, fired it up, and kept hearing a fizzle sound by the exhaust manifold. I thought I had a water leak, but once I ran my hand around the side I noticed it was oil. I kept wondering why everytime I would put oil in it it would drain out.
    I figure a new one will do the trick just trying to see if there is a quick fix to test this ski out. Halomar?
    SHOOTER
    stock headbolts or studs?

  4. #4
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    I went ahead and stuck the oring back in it, right stuff sealant on it for now. Going to get a new oring tomorrow or sometime next week. Bolts. Thanks Rich.
    Jason, why you say new valve cover?
    SHOOTER

  5. #5
    BLACK MAGIC HEADERS hydrojunkie's Avatar
    Join Date
    Jun 2007
    Location
    new york
    Posts
    3,529
    +1
    3
    Quote Originally Posted by shooter98xpl View Post
    I went ahead and stuck the oring back in it, right stuff sealant on it for now. Going to get a new oring tomorrow or sometime next week. Bolts. Thanks Rich.
    Jason, why you say new valve cover?
    SHOOTER
    cracked cover warped, its leaking at the valve cover not the bott of the head correct

  6. #6
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    right where the valve cover squeezes down on the head. The oring there is not sealing up or warped valve cover. But how would one warp the valve cover?
    SHOOTER

  7. #7
    BLACK MAGIC HEADERS hydrojunkie's Avatar
    Join Date
    Jun 2007
    Location
    new york
    Posts
    3,529
    +1
    3
    Quote Originally Posted by shooter98xpl View Post
    right where the valve cover squeezes down on the head. The oring there is not sealing up or warped valve cover. But how would one warp the valve cover?
    SHOOTER
    your head could be damaged too. pull the cover off and put a stright object like a carpenters square and see if thats damaged.

  8. #8
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    J I went ahead and did what you said. Head is pretty darn good. I did a quick seal job and found where its actually leaking at. Between the rubber gasket and the top of the valve cover. I copper sealed it all back up and waiting to see what it will do Friday. I ordered a new rubber gasket, it seems to be the culprit as it was coming out right between the cover and rubber gasket.
    Let you know how it goes friday and then when I get the new one.
    SHOOTER
    p.s. thanks

  9. #9
    BLACK MAGIC HEADERS hydrojunkie's Avatar
    Join Date
    Jun 2007
    Location
    new york
    Posts
    3,529
    +1
    3
    Quote Originally Posted by shooter98xpl View Post
    J I went ahead and did what you said. Head is pretty darn good. I did a quick seal job and found where its actually leaking at. Between the rubber gasket and the top of the valve cover. I copper sealed it all back up and waiting to see what it will do Friday. I ordered a new rubber gasket, it seems to be the culprit as it was coming out right between the cover and rubber gasket.
    Let you know how it goes friday and then when I get the new one.
    SHOOTER
    p.s. thanks
    no worries mate

  10. #10
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    So my seal job held up pretty damn good. But now when I pull the dipstick out of the holder it blows out air. Is my tops valve bad or is it something else? I don't think it should schwooooosh when you pull the dipstick, hahaha. Any ideas?
    SHOOTER

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Valve cover block off
    By Kawi15f#12 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 10-21-2007, 07:24 PM
  2. Valve cover gasket leaking oil
    By EGGonz in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 09-15-2007, 10:04 AM
  3. hole drilled in top of rave valve cover, why?
    By JLewis in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-25-2007, 07:11 AM
  4. Pulling Valve Cover
    By JimC in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-13-2007, 04:41 PM
  5. Air suction block offs (aka: Valve Cover block offs)
    By earthshaker in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-19-2007, 08:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •