Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1
    Flynfox's Avatar
    Join Date
    Aug 2006
    Location
    Sunny SC
    Posts
    682

    Question Did I lose the supercharger?

    I was out on the lake today with 8 hrs on my '06 RXP.

    I was hoping to get 10 hrs, get the 10 service done & then start my mods. After 15 miles & about a 5 sec WOT burst I slowed down to cruise through a No Wake zone. Approx 5 mins later I gave it some gas, not full throttle, and felt a terrible vibration. At first I thought I was dragging on something but not the case.

    Unfortunately, I had no choice but to cruise back to the ramp, which was about 17 miles, at 20-30 MPH. I can still hear S/C though and I didn't hear any odd noises???

    BTW - I have run the ski during the break-in period but I nvr thrashed it.

    So what do you think?


  2. #2
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    Sounds like something is lodged in your pump. It isnt the super charger.

  3. #3
    Flynfox's Avatar
    Join Date
    Aug 2006
    Location
    Sunny SC
    Posts
    682

    Post

    Yeah that's kinda what I thought but I can't see anything. Guess I'll go ahead and take it in for the 10 hr service, I'm @ 9.5 anyway, and have the dealer figure it out.

  4. #4

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965
    How deep was the water as you accelerated out of the no wake zone?

  5. #5
    Flynfox's Avatar
    Join Date
    Aug 2006
    Location
    Sunny SC
    Posts
    682

    Post

    Well I was in the channel the whole time so I'm sure it was at least 20 feet or deeper. The one thing I did notice though was there were a lot more leaves than usual but I didn't seem like enough to clog my pump.

    The only other thing I just remembered is last weekend I took my ski out with a friend to a river that is known for debris. In fact his ski got clogged but mine seemed fine the rest of the day. And today all was well until I gassed it from the No Wake zone. I had already put 1 hr on it & did a top speed burst @ 8100 + RPM...
    Last edited by Flynfox; 11-19-2006 at 05:28 PM.

  6. #6

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965
    Chunk of wood?

  7. #7
    Yeah, prolly foliage and crap in the water, doesn`t take much to make the ski shake... if yoiu can still hear the whine, then you still have the SC...PR...

  8. #8
    Flynfox's Avatar
    Join Date
    Aug 2006
    Location
    Sunny SC
    Posts
    682

    Question

    Quote Originally Posted by Pale Rider View Post
    Yeah, prolly foliage and crap in the water, doesn`t take much to make the ski shake... if yoiu can still hear the whine, then you still have the SC...PR...
    #$%* r u kidding? I had no idea they could get clogged so easy! Makes me want a boat...

    So what now? I looked up in the grate but I didn't see anything.

    Like I said earlier I am due for the 10 hr service so I'll have the dealer check it out but what about next time?

  9. #9
    most leaves, pine needles, some seaweed etc will just turn to coleslaw, but eel grass in clumps can really get jambed in there. If you rode for any lenght of time for 20-30mph, it doesn`t sound like it`s stuck...you still have vibration? if so you could have bent up the prop and killed the wear ring???

    I recently sucked up rocks (for the first time) and it destroyed my new skat prop, most likely bc I had a stainless wear ring and there is no forgivness with one of them...PR...

  10. #10
    Flynfox's Avatar
    Join Date
    Aug 2006
    Location
    Sunny SC
    Posts
    682

    Question

    Hmmm. Well, I agree that it's probably not the S/C. The vibration did seem to get better on the way back but it's still there and I didn't really want to run it hard not knowing what was wrong.

    I'm almost pos it wasn't rocks but would maybe a chunk of wood do it? Wouldn't I have heard something? Is it possible I just had a defective pump?

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How do I remove the supercharger???
    By WildBill9000 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 05-21-2006, 10:17 PM
  2. When did all of the Exhaust kits go out?
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-17-2006, 01:27 PM
  3. How much HP does the supercharger warning sticker add?
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 12-22-2005, 02:46 PM
  4. Did I hit the rev limiter or a fish?
    By Mark S in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-03-2005, 10:48 PM
  5. who knows if Seadoo will cure the supercharger issue in 2006
    By rxp_boy in forum 4-Tec Performance
    Replies: 26
    Last Post: 07-17-2005, 09:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •