Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524

    Ever break a pump shaft?

    I did yesterday while out on Careys ski

    When it happened i thought i threw a rod thru the block. The engine started to lose power, lots of banging and clanking and then a horrible BANG/Screech and the engine died. I popped the seat and water was half way up the supercharger.

    I was lucky to have Rocko from here on the forum and another friend riding with me. We pulled it up onto the bank and drained it. I grabed the drivshaft and could move it around quite a bit and realized something in the driveline gave out so we just towed it back in.

    When i got home and pulled the pump i found the pump shaft broke causing the driveshat and impeller to flop around causing the carbon seal to leak and the impeller wore off the back of the shark's teeth in the pump shoe and wore a groove into it. Im very fortunate the engine didn't take on water. It runs fine!

    By the way, this was an Impros modded double bearing pump with sealed bearings. Looks like i'll be sending this one in for the Skat tripple bearing mod.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	broken1.jpg 
Views:	52 
Size:	158.3 KB 
ID:	10906   Click image for larger version. 

Name:	broken2.jpg 
Views:	62 
Size:	169.4 KB 
ID:	10907   Click image for larger version. 

Name:	broken3.jpg 
Views:	55 
Size:	147.1 KB 
ID:	10908  


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    After just changing the pump shoe in my ski and seeing what a pain in the ass it was i decided to just clean her's up and give it a shot. If it decreases performance then i'll change it
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	broken4.jpg 
Views:	58 
Size:	129.7 KB 
ID:	10909  

  3. #3
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,071
    +1
    790
    Jerry do you need one asap? I have one you can have if you want it?

    Just send me you addy and I will ship it out tomorrow.

    Sorry to see the mess. It tore it up bad.... Anothere pump shoe comming.


    Let me know..


    .

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Thanks for the offer Austin. I appreciate it, but i have a spare. Thanks!

  5. #5
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23

    whoa, is this a first for a 4tec ?

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    I have never heard of one breaking on a 4 tec. Keep in mind this isn't a stock pump nor a Skat tripple bearing. This was an old Impros modded double sealed bearing pump. I think one of the bearings seized causing the shaft to snap.

  7. #7
    Holy sheep dip Jerry I`ll tell ya, you have more patience than I, glad you recovered ski ok and your ok! That had to scare the bejesus out of ya. are you just gonna take the shark teeth off totally? What spare do you have?...PR...

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Yea, it scared the frick out of me. It sounded like i threw a rod. Then when i popped the seat and saw the water i was sure i hydrolocked it. I was very lucky. I waste no time either, her ski is already back running

    I am leaving the shark teeth because they are still intact. Just the back of them were worn down a bit.

    I had a spare tripple bearing pump that i put in it.

  9. #9
    Again, learning from your own experience that we help others! I have not see this issue on a 4 tec. Do you think the stock bearing would of been toast along time ago? Just Curious!

  10. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    I think the stock bearing would have been fine. Its just that this pump had sealed bearings so there was no way to get grease, or oil to them.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Great tips for removing stuck Pump shaft
    By hopeful1 in forum Yamaha How To & FAQs
    Replies: 23
    Last Post: 02-28-2017, 02:08 AM
  2. Stator pump shaft seals
    By scorp in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 05-03-2009, 09:43 PM
  3. Great tips for removing stuck Pump shaft
    By hopeful1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 01-06-2008, 12:08 AM
  4. Pump shaft wont come out of the intermediate
    By MNAPR in forum Yamaha How To & FAQs
    Replies: 13
    Last Post: 10-22-2007, 08:15 AM
  5. Awesome ride today in South LA! Ever pull the pump with the OEM tool kit?
    By engineermike in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 04-04-2007, 06:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •