Results 1 to 8 of 8
  1. #1
    JOHN SPY's Avatar
    Join Date
    Jun 2010
    Location
    GREECE ATHENS
    Posts
    14

    Vts prob going only down

    So,i have an rxt-x 2008 & have prob with th vts...its going only down.
    Checked plugs,motor,all the housing,fuse (7.5)...all.
    Whats going on???
    thanks in advance!!


  2. #2
    JOHN SPY's Avatar
    Join Date
    Jun 2010
    Location
    GREECE ATHENS
    Posts
    14
    tt

  3. #3
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,691
    +1
    40
    Vts switch.....

  4. #4
    JOHN SPY's Avatar
    Join Date
    Jun 2010
    Location
    GREECE ATHENS
    Posts
    14
    Thanks DIMITRI,after a good look it was a bad pin connect of a single cable of the harness.

  5. #5
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,691
    +1
    40
    Anytime John!

  6. #6
    Hey Guys,

    I am having the exact same issue with my RXP-X.. It wont go up, but it goes all the way down..
    Might I add both of the buttons only had worked when pressed down and mashed really hard ..
    The top one was working fine for a bit a couple of weeks ago and then it just stopped working.. Now it is stuck at its lowest point.

    John Spy- Where is the harness located so I can check for a bad pin connection?? I am new to all of this and any help would be greatlky appreciated.
    I have checked the fuse and its fine..

    I would love to get this fixed before the weekend.. I want to take it out

    Is there any way for the trim to be manually adjusted, I dont feel comfortable riding it in the surf this weekend with the trim all the way down.

    Thanks Guys

    Stippa

  7. #7
    Also, just wondering

    I just bought a switch from an auto electircal place.. Would the computer on the ski have issues if I cut the wires from the OEM switch and connect them to this new switch?

    Thanks in Advance

  8. #8
    Found the problem last night!!
    It was the switch.. I had to cut it open, sand back the connectors and it worked fine

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rxp 215 vts indicator going crazy
    By Tanner215 in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-16-2016, 08:33 PM
  2. Vts getting stock at down position!!!! Help
    By speedjunky787 in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-31-2014, 07:14 PM
  3. Replies: 4
    Last Post: 08-30-2011, 11:02 AM
  4. only 1.2 left to go...
    By JP in forum 4-Tec Performance
    Replies: 33
    Last Post: 04-25-2007, 05:43 AM
  5. Replies: 21
    Last Post: 08-15-2006, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •