Results 1 to 3 of 3
  1. #1

    Unhappy 97 Speedster - Starboard engine will not start

    I own a 97 speedster for 3 years and love it! Last fall I was having problems starting starboard engine. Once it was started the engine was fine. The starboard engine always cranked slower. I winterized the engines last fall.
    Now I went to start the engines and the port engine (closes to battery) fired right up no problems. The starboard engine will not start. Pulled the plugs and gray soup (oil and water) came shooting out of engine (about thirty feet high). Ran all of the gray fluid out of engine and can not get engine to start.

    1. Is there an issue with these speedsters with the battery cable so far away from engine?
    I put on new starter and still cranks slower. With both engines spark plugs removed they rotate at the same speed. This tells me the water pump is free.

    Iím getting good spark.
    I have good compression.
    Iíve tried other engines spark plugs.

    I guess the oil and water mixture came from last year towing the seadoo without crimping water line. This is the last time speedster was running.

    HELP !!! Spring is here and my speedster is not running!


  2. #2

    Join Date
    May 2007
    Location
    Miami FL
    Posts
    22
    I am not an expert but if the boat sat for the winter with water in the engine then that engine is probably all rusted inside. Its a miracle that is turning over. Unless is not water what you saw coming out of it.

  3. #3
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Quote Originally Posted by cjb View Post
    I am not an expert but if the boat sat for the winter with water in the engine then that engine is probably all rusted inside. Its a miracle that is turning over. Unless is not water what you saw coming out of it.
    +1

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 GTI Turns over will not Start - Fails Timer Verification Test
    By mfmeyer in forum 2-Stroke Performance
    Replies: 4
    Last Post: 08-07-2015, 02:52 AM
  2. Engine will not start, only with starter spray
    By xa1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 10-10-2014, 07:53 PM
  3. will improper timing cause engine to not start 750 SLT
    By youngone in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-26-2013, 10:41 AM
  4. No spark from spark plugs the engine will not start?
    By Discokaj in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-29-2010, 03:08 PM
  5. Engine Will not Start (please help)
    By Hugofromlp in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 08-27-2008, 08:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •