Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    pokechop2006's Avatar
    Join Date
    Jun 2009
    Location
    summerville sc
    Posts
    223

    sending unit sticking on my 150

    well went out sat for the first time an noticed that the gas guage was reading empty,rode for a bit an it came up in spurts then went down some an back up a bar,now all it reads is empty,gonna pull sending unit an was wondering how much of a pain was it to get out of the tank?


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    It's a pain. Gotta pull the engine.

  3. #3
    I'd rather be jet skiing Saltwater n Premix's Avatar
    Join Date
    Jul 2010
    Location
    Fort Worth, TX
    Posts
    514
    +1
    47
    Yes it is. Mine sticks at around half tank and occasionally drops down when I get really low. I just keep an eye on how much gas I have in it.

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    I've got to pull the one on my STX...

  5. #5
    Yea it's a pain. That's why I never pulled mine I just fill it up everytime and know that I can ride for 3 hrs with no problem.

  6. #6
    pokechop2006's Avatar
    Join Date
    Jun 2009
    Location
    summerville sc
    Posts
    223
    well guys i found out you dont have to pull the motor an actually its not hard to do,the worse part is taking off the pads on the side of the hull to get to the bolts for the center cross brace.once the brace is out the sender will come on up an out,yull just have to glue the pads back in place or better use double sided tape.my parts bike sender was no good too when i looked up the part on line in two different places both said the part was less than 4 bucks does that sound unbelivable?im going to the local bike shop today an ordering from them that way if its wrong its on them.

  7. #7
    I'd rather be jet skiing Saltwater n Premix's Avatar
    Join Date
    Jul 2010
    Location
    Fort Worth, TX
    Posts
    514
    +1
    47
    You got my attention, if it's as easy as you just made it sound, I'm down.

  8. #8
    x2ryder's Avatar
    Join Date
    Mar 2007
    Location
    Moline, Illinois
    Posts
    407
    Yeah all you have to do is pull out the center brace. Reglueing the pads is the biggest pain out of all of it.

  9. #9
    pokechop2006's Avatar
    Join Date
    Jun 2009
    Location
    summerville sc
    Posts
    223
    yea found out that i was looking at the wrong thing on the microfish the part i need is 320 bones at the dealership OUCH!

  10. #10
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    I'd try to fix it somehow before buying another one. You see them periodically on Ebay. Make sure you get the correct one for your model year, as they are not all the same.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts Need fuel sending unit for 1999 Ultra 150
    By thetolleyman in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 04-20-2015, 06:15 PM
  2. Battery Indicator flashing on my 150 Ultra
    By Christophhhh in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-01-2010, 06:23 PM
  3. how to test oil sending unit on 99 STX
    By jdy2kgt in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-20-2009, 04:50 PM
  4. help, don't know how to tune the carbs on my 2001 ultra 150
    By hal8611 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-01-2009, 10:52 PM
  5. couple 150+ mph passes on my old R6.....
    By VFX_Artist in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 12-09-2005, 01:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •