Results 1 to 4 of 4
  1. #1

    Driveshaft Experts please look - PICS

    Click image for larger version. 

Name:	IMG_7036MOD.jpg 
Views:	35 
Size:	69.4 KB 
ID:	235340Click image for larger version. 

Name:	IMG_7034MOD.jpg 
Views:	32 
Size:	55.8 KB 
ID:	235339


    Click image for larger version. 

Name:	IMG_7037MOD2.jpg 
Views:	28 
Size:	29.6 KB 
ID:	235338Click image for larger version. 

Name:	IMG_7035MOD.jpg 
Views:	38 
Size:	43.0 KB 
ID:	235337

    Okay, enough self-debating....I was able to capture well enough some close-ups of my driveshaft markings that have me puzzled as to whether or not I should spend near $300 on a new OEM shaft.

    For those of you who dont know yet, these are markings Ive noticed since after my mishap last thursday of my C-clip falling out of the floating ring/shaft after 1.5hrs of riding with my new carbon seal and boot.

    Please tell me what you guys know (More pics coming now...)


  2. #2
    Oh for Christs sake how do you continue with posts with additional pics?

    where/what is the URL greenhulk is asking me for....these pics are in my hard drive....just as i grabbed them for the fist post.

  3. #3
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    That clip is done! The ridges are signs of wear against the shaft groove. Get a new clip & you'll be ok, After the new clip is installed A good test and easy check is to put a rubber band or zip tie on the throttle to WOT & with the seat off and the carbon ring area in sight crank the motor & see if the metal top hat thingy wobbles, if not you're good, if so you'll need a new shaft.

  4. #4
    "Part 2" thread (for the additional pics upload )

    http://www.greenhulk.net/forums/show...ts-PICS-Part-2

    ---------- Post added at 12:59 AM ---------- Previous post was at 12:56 AM ----------

    Quote Originally Posted by ou812 View Post
    That clip is done! The ridges are signs of wear against the shaft groove. Get a new clip & you'll be ok, After the new clip is installed A good test and easy check is to put a rubber band or zip tie on the throttle to WOT & with the seat off and the carbon ring area in sight crank the motor & see if the metal top hat thingy wobbles, if not you're good, if so you'll need a new shaft.
    Wouldnt the new O rings in the floating ring keep it from wobbling....and would simply cranking it over be enough to make a loose floating ring wobble anyway?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2014 FZS, please look at engine pic and help
    By jwaked in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 07-08-2014, 07:50 PM
  2. Replies: 11
    Last Post: 07-15-2013, 11:30 AM
  3. Driveshaft Experts - PICS - Part #2
    By blkturbo! in forum 4-Tec Performance
    Replies: 33
    Last Post: 04-13-2011, 04:31 PM
  4. Impeller-to-Driveshaft Help please!
    By blkturbo! in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-12-2007, 04:23 PM
  5. Everybody please look.......
    By TCR in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 08-15-2006, 10:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •