Results 1 to 10 of 10
  1. #1

    Mikuni throttle cable...is this setup right?

    At cigarlust's place trying to figure out why his throttle cable isn't working right. When separate the cable slides smoothly and the carbs spring back perfectly....put them together and it gets stuck wide open. What's wrong?

    Forefoot the pic loads from my phone.

    Sent from my HTC Evo using Tapatalk
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	uploadfromtaptalk1302826220826.jpg 
Views:	76 
Size:	65.8 KB 
ID:	235652  


  2. #2
    It's a JEEP thing...You wouldn't Understand dirtdude35's Avatar
    Join Date
    May 2009
    Location
    Hurst tx
    Posts
    473
    looks right to me... mine was doing that but just stopped. so i am not sure what is wrong.

  3. #3
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,139
    +1
    1,050
    When disconnected, is there any excessive play in the throttle shafts? And when connected and in the WOT position, are any of the throttle plates "hanging up" on either side of the carb bores?

  4. #4
    Figured it out....turned out the throttle lever was binding on his new grips...they had an aluminum collar that was a little wider than the rest of the grip and the lever is just a tad too narrow to go over them. We sat there and fiddled with it for a good 30 minutes before catching it. And then I broke throttle lever in half! I found a spare in my stockpile and it looks a little wider than that one he had...plus I think he's going to grind the grip collar down a little.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by bgaidan View Post
    ...put them together and it gets stuck wide open. What's wrong?...
    Is there any misalignment between the cable sleeve and the throttle shaft cam? Is the cable cam bent or twisted?

  6. #6
    Quote Originally Posted by K447 View Post
    Is there any misalignment between the cable sleeve and the throttle shaft cam? Is the cable cam bent or twisted?
    Pssst....read all the replies before replying!

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    You installed the Odi grips with the stock thumb throttle didn't you?????



    Ask me how I know.........


    Same scenerio.


    Ground the collar down just a tad to narrow it, and that's all it needed. I however like the finger throttle myself, and wouldn't cause an issue with the grips at all.



    Unfortunately we had just installed the new grips. My boss came out for the first time last year and he hopped on that ski. He kept telling us the throttle was sticking. I thought he was crazy. After all, I just replaced the grips and didn't notice a problem.... (never pinned it WOT though)

    Long story short, after 20 mins he was heading back in with a broken toe. And of course the sticking throttle was his excuse.

    After he left for the hospital, we found the problem. Same thing as you.


    Odi grips and stock thumb throttles require extra attention.

  8. #8
    Quote Originally Posted by xlint89 View Post
    You installed the Odi grips with the stock thumb throttle didn't you?????

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by bgaidan View Post
    Pssst....read all the replies before replying!
    Less than 180 seconds between our posts. I was typing while you were posting

  10. #10
    cigarlust's Avatar
    Join Date
    Apr 2008
    Location
    Funky town (Fort Worth TX)
    Posts
    1,171
    +1
    2
    HUGE thanks to Brian for coming over and helping me out tonight, I'm mechanical, and was about to start beating myself up trying to figure it out... Brian got stumped for a few too, and made the comment, it's got to be something really easy, then Brian noticed the ODI's were causing the problem. I can't to get her out this weekend!

    I think this will be a fun little ski, it'll be the first Polaris I've owned... I know my Honda is quicker, and my FXHO cruises real nice... but I've wanted a smaller sit down ski for a while

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 08-12-2010, 12:55 PM
  2. GPR Throttle Cable - Is there an aftermarket option?
    By wreckingball in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 07-09-2010, 12:36 PM
  3. Is this the right tool?
    By polaris 750SL in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-09-2010, 05:00 PM
  4. 1300 Jetting - Is this still right ?
    By mrbtd in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 01-03-2008, 03:42 PM
  5. Castrol Oil, is this the right one?
    By ramnj in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-05-2006, 04:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •