Results 1 to 3 of 3
  1. #1

    900zxi trim question

    So i'm in the process of rebuilding my trim box on my 1995 900zxi. I have a new motor and trim sensor but it still doesn't work.. I found a small white box containing a circuit board inside and it is corroded badly (motor control board?) Think this is the culprit? wonder where i can get one without going through kawasaki? any help would be great


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,011
    +1
    283
    I doubt that you can get one aftermarket. You might find one on Ebay, or here, or PWC Today.

    Make sure you seal the case halves when you put it back together. Also, make sure the bellows seal on the cable (at the back of the boat) is in good shape. Water can work it's way up the cable into the box.

  3. #3

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 SL-750 trim questions
    By skigolfnut in forum Polaris Open Discussion
    Replies: 3
    Last Post: 03-10-2010, 12:54 PM
  2. GP760 Trim Question
    By kaarona1 in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 10-01-2008, 01:04 PM
  3. GP760 Trim Question
    By kaarona1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-30-2008, 10:38 AM
  4. 95 polaris slx 780 trim question
    By slx780 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 02-05-2008, 06:16 PM
  5. Quick Trim Question
    By jsc7002 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 07-14-2007, 09:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •