Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Unhappy Bought a 2007 F12X and wont go over 25mph

    Hi, just looking for information that may lead into a solution to resolve my issue with my Aquatrax F12X Turbo. I took it out to the Isle Morada (florida Keys) and when I took off the response was very slow (10-13 mph) with throttle pulled to the max, then jumped into 25mph and it was just that...wouldn't go over that at all.

    I have researched in this forum looking for close answers and got really good tips to work on it this upcoming weekend. I have checked the spark plugs, oil level and cooling system and those areas are fine and in good shape. Any ideas??

    Thanks for the help!!


  2. #2
    Banned User
    Join Date
    Nov 2009
    Posts
    50
    are u gettin any codes

  3. #3
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    Quote Originally Posted by Miami_Traxf12 View Post
    Hi, just looking for information that may lead into a solution to resolve my issue with my Aquatrax F12X Turbo. I took it out to the Isle Morada (florida Keys) and when I took off the response was very slow (10-13 mph) with throttle pulled to the max, then jumped into 25mph and it was just that...wouldn't go over that at all.

    I have researched in this forum looking for close answers and got really good tips to work on it this upcoming weekend. I have checked the spark plugs, oil level and cooling system and those areas are fine and in good shape. Any ideas??
    .
    Thanks for the help!!
    Usually if it is not flashing a FI malfunction on the dash, your turbo is either stuck or your wastegate is stuck open. If you are mechanically inclined, then pull the large center tube off the middle of your turbo. Crank the engine and see if the turbo is spinning. Be careful not to drop anything into the fragile compressor wheel. If it is not spinning then carefully turn the tiny nut in the center of the compressor wheel to see if it will turn. Do not loosen the nut or snap it off. A new Honda turbo is almost $3K.
    If that does not fix it call Ramon at H20Xtreme.net and see if he will take time to help you.

  4. #4
    I will check on those tonight.

    ---------- Post added at 12:22 PM ---------- Previous post was at 12:17 PM ----------

    Should I do this with hose attached to the back of the Ski to prevent overheat?

    ---------- Post added at 12:23 PM ---------- Previous post was at 12:22 PM ----------

    Sorry but I am a newby on the Ski world...

  5. #5
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    Once you have the air tube off the turbo, you can crank it for a minute to see if the turbo spins. You won't need the hose for just a minute of run time.

  6. #6
    Got it.. will do it in the AM hours tomorrow. will post here on what I find out tomorrow..

  7. #7
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    [QUOTE=Miami_Traxf12;1674887]Hi, just looking for information that may lead into a solution to resolve my issue with my Aquatrax F12X Turbo. I took it out to the Isle Morada (florida Keys) and when I took off the response was very slow (10-13 mph) with throttle pulled to the max, then jumped into 25mph and it was just that...wouldn't go over that at all.

    I have researched in this forum looking for close answers and got really good tips to work on it this upcoming weekend. I have checked the spark plugs, oil level and cooling system and those areas are fine and in good shape. Any ideas??

    Sounds like you got a fast one! LOL! Sorry... couldn't resist!

  8. #8
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    [QUOTE=Vman;1676096]
    Quote Originally Posted by Miami_Traxf12 View Post
    Hi, just looking for information that may lead into a solution to resolve my issue with my Aquatrax F12X Turbo. I took it out to the Isle Morada (florida Keys) and when I took off the response was very slow (10-13 mph) with throttle pulled to the max, then jumped into 25mph and it was just that...wouldn't go over that at all.

    I have researched in this forum looking for close answers and got really good tips to work on it this upcoming weekend. I have checked the spark plugs, oil level and cooling system and those areas are fine and in good shape. Any ideas??

    Sounds like you got a fast one! LOL! Sorry... couldn't resist!
    He was still faster than the SeeeeeDoooos and Yamahas with blown superchargers or cracked nano-hulls.....

  9. #9

    Thumbs down

    Well just took off the center tube of the Turbo. look like the turbo is stucked.. i need to crank it up to confirm.. i really dont want to think i need to buy a new turbo [COLOR="Silver"]

    ---------- Post added at 03:32 PM ---------- Previous post was at 03:31 PM ----------

    [QUOTE=JRINJAX;1676194]
    Quote Originally Posted by Vman View Post

    He was still faster than the SeeeeeDoooos and Yamahas with blown superchargers or cracked nano-hulls.....

    well just like I thought, the Turbo blades aren't spinning, so I guess it's stuck!!. Any ideas on how to fix this or do I have to start thinking on buying a new turbo??

  10. #10
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    First use a small metric socket on the small nut on the center of the compressor wheel and gently turn it to see if it will break loose. Do not loosen the nut/tighten only!
    If that doesn't do it get with Ramon about their turbo upgrade [$1275.00].

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 06-04-2012, 07:01 AM
  2. zxi 1100 took on water and wont go over 20
    By meader in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 06-22-2010, 01:28 PM
  3. gpr 1200 that wont go over 3mph and will die if throttle let off
    By SpeedFreak in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 06-11-2010, 07:39 PM
  4. 900zxi bogs and wont go over 40 mph
    By philsmtech in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 06-30-2008, 01:09 PM
  5. 07 rxp suffering a miss and wont go over 6500rpm
    By wonka in forum 4-Tec Performance
    Replies: 48
    Last Post: 05-11-2008, 04:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •