Results 1 to 2 of 2

Thread: XL800 problem

  1. #1
    redbarron's Avatar
    Join Date
    Apr 2011
    Jacksonville, FL

    XL800 problem

    I have a XL800 that I bought new in 2001 and she is finally giving me some problems. Last summer the ski has a very hard time getting on plane, it will take a long time to get on plane and soon as it starts to plane the RPM will shoot up and it will go like normal. It runs fine with just my self a slight hesitation down low, but once I get two or three people on the ski the rpm will say low and not rev enough to get on plane. One thing I noticed is that the power valve servo is not moving at all, which leads me to believe the servo is not working or a issue with the power valves. The ski has about 240hours on it.

  2. #2
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Houston, Texas
    I just have the same boat in the shop with the same problems

    it was a bad servo motor

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 xl800 part out
    By WaveDemon in forum Yamaha Classifieds
    Replies: 6
    Last Post: 03-28-2011, 05:39 AM
  2. xl800 tips
    By RHeller1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-05-2008, 09:23 PM
  3. Opinions on XL800
    By KurtS in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 07-28-2008, 02:32 PM
  4. XL800
    By XL800 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-13-2008, 08:45 PM
  5. XL800 almost back together, one more ?
    By havanabama in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 01-30-2008, 07:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts