Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Full Throttle or Broke!!! UNSANE's Avatar
    Join Date
    Aug 2008
    Location
    Orlando
    Posts
    721
    +1
    82

    Pulling to the Left

    2010 iS, module and 15/22 Solas, stock grate. Seems to be really pulling to the left big time when I relax the steering. I had no wind or current and was in very protected water that was glass smooth. If I lean over to the right side of the ski, it starts to balance out. If I straighten out the ski, it scrubs speed. I'm also having some slip issues as I'm maxxing out the rpm's (8100). She's running almost 72 on my Garmin.

    I read some other threads where people were pulling to the right, but not the left. I'm guessing something's out of alignment and am wondering if I should get a new Worx Grate first, then deal with the drifting. Also, is this something I can do or is there a special tool required because an alignment is more complicated?


  2. #2
    eric1238's Avatar
    Join Date
    Jun 2005
    Location
    Smith Mtn. Lake VA
    Posts
    728
    +1
    2
    Check the pump bolts that go into the plate

  3. #3
    Full Throttle or Broke!!! UNSANE's Avatar
    Join Date
    Aug 2008
    Location
    Orlando
    Posts
    721
    +1
    82
    Quote Originally Posted by eric1238 View Post
    Check the pump bolts that go into the plate
    Looks good as far as I can tell. Tried to move the assembly and it seemed tight.

  4. #4
    Gomer Pyle starter99's Avatar
    Join Date
    Sep 2009
    Location
    GA
    Posts
    642
    +1
    54
    adjust the streering i think the adjustment under the gauge cluster that what i done mine was doning the samething do u have stock ecu? are u in the usa?

  5. #5
    Full Throttle or Broke!!! UNSANE's Avatar
    Join Date
    Aug 2008
    Location
    Orlando
    Posts
    721
    +1
    82
    Quote Originally Posted by starter99 View Post
    adjust the streering i think the adjustment under the gauge cluster that what i done mine was doning the samething do u have stock ecu? are u in the usa?
    Speed Limiter bypassed and Solas 15/22 installed. In Florida.

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    So when you relax your grip on the handle bars the ski pulls to the left? Not when you are running straight the bars are turned to the right?

  7. #7
    Full Throttle or Broke!!! UNSANE's Avatar
    Join Date
    Aug 2008
    Location
    Orlando
    Posts
    721
    +1
    82
    Quote Originally Posted by troyheb View Post
    So when you relax your grip on the handle bars the ski pulls to the left? Not when you are running straight the bars are turned to the right?
    To make the ski go straight, I have to turn the bars to the right and it will scrub some speed. If I lean over to the right side of the ski, she'll balance out as well. When I relax and the bars straighten out, the ski starts arcing left.

  8. #8
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    Check your intake grate as it might be tweeked/bent or not installed flush to the hull

  9. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Check the sponson on the left side for damage or mounted lower than right side. Also scope out the opas on the left side.

  10. #10
    skiskeet's Avatar
    Join Date
    May 2010
    Location
    union nj
    Posts
    47
    happend on my friends tx turned out being the opas check that out

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I (had) a bad pull to the left
    By Pistonwash in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 02-15-2009, 07:33 PM
  2. VTS Problem - Pulling to the Left when Trimmed up 100%
    By ImAcoustic in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-17-2008, 02:11 PM
  3. Pulling to the left after being at dealer
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 06-24-2008, 11:31 AM
  4. Steering pulling to the left / Speedo
    By MrSxy4Ever in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 05-14-2007, 11:36 AM
  5. '06 GPR pulls to the left ?
    By steach in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 08-18-2006, 10:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •