Results 1 to 7 of 7
  1. #1

    polaris genisis no spark

    allright guys i have a problem with my 2000 genisis carbureted i dont have a spark i was rideing along and it cut out so i towed it back the battery was flat changed the battery and it started took the battery off left it over night and tryed it again and i dont have a spark now can anyone please cheers wayne


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    34
    Welcome to Green Hulk.
    You need 10.6 volts while cranking to have spark.
    Sounds like you have weak battery's.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Welcome to the Hulk

  4. #4
    got 10.8 volts tryed a new battery and still no spark cheers casey its not easy to get spares here in scotland for polaris

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by weefeet1200 View Post
    got 10.8 volts tryed a new battery and still no spark ...
    Well, work through the diagnostics

    Hold down the Bilge button. Does the bilge pump run? It should.
    Continue holding down Bilge button and press Start - do you have spark?

    Isolate the Black/Yellow ignition kill wire (lanyard switch). Unplug the switch wire at the terminal board, have spark now?

    Ohm test the stator coils and Hall Effect sensors.

  6. #6
    sorry for the delay guys but the bilge works still no spark, the lanyard disconnected still no spark, the stator cheques ok

    but i don't know how to test the coils. can anyone give me a idiots guide on how to do that?

    also the cdi idiots guide, if not a good rope as I'm at my wits end with this ski

    cheers guys

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Polaris Domestic (red) engine

    You need to work through the diagnostics step by step.

    No harm in ohm testing the ignition coils, but they rarely fail. Make sure the grounding is solidly connected within the electrical box, and all grounds measure zero ohms back to the engine block.

    Look up how to bypass the Start/Stop module and do that.

    The tests for your Gen III domestic ignition stator are on the linked page above.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris virage no spark, HELP!
    By robmeyer in forum Polaris Open Discussion
    Replies: 25
    Last Post: 06-12-2017, 12:29 PM
  2. 94 Polaris SL650 No spark
    By ChopperPilot08 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-06-2008, 06:37 PM
  3. Polaris 800DI no spark
    By Bear in forum Polaris Open Discussion
    Replies: 16
    Last Post: 05-09-2008, 05:34 AM
  4. 2002 polaris virage no spark
    By maples32 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 03-13-2008, 09:43 PM
  5. 2001 polaris virage no spark & no fuel
    By paintballer89 in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 05-01-2007, 07:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •