Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 39
  1. #1
    Rxpx guy's Avatar
    Join Date
    Apr 2011
    Location
    Monroe, La
    Posts
    20

    Unhappy Wal-Mart gas power loss

    So I just bought a 2008 RXP-X with 20 hrs on it. I took it out the first time and it ran like a scalded dog. Speedo read 70mph. It already had a 1/2 tank of gas when I bought it and I have no idea where the gas was purchased. A few days later I went by walmart and filled it up again with 93 octane. It says on the pump that it may contain up to 10% ethanol. When I put it on the water it didn't have nearly the power it had the last time it was out. I could only get 64 mph on the speedo and it was sloooow getting there. Has anybody else had this problem or do I need to start planning to fix something that's broken? Thanks


  2. #2

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    I doubt walmart was the problem. I buy my gas anywhere its cheap. Always 92 or 93 though.

  3. #3
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    You've got another problem, it is just coincidental. It is chitty gas, but it won't cause that kind of loss. Sounds more like S/C issues, slip.

  4. #4
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330
    Walmart sells gas???? Where do you guys live????

  5. #5

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    I know meijer does by us. I haven't seen a walmart gas station I dont think.

  6. #6
    Rxpx guy's Avatar
    Join Date
    Apr 2011
    Location
    Monroe, La
    Posts
    20
    Well, I know a guy that told me he used to have to watch where he got gas for his jet ski because he had the same problem. So I'm gonna fill it up with some non-ethanol gas and see what happens. If that doesn't help then I'll take it to a shop I guess. S/C slip at 20 hours? The thing is practically brand new. After talking to this guy and reading this (http://www.skyroadster.com/forums/f2...engines-25618/), it makes sense that the gas could be my problem. I could believe it would be mechanical a little easier if it wasn't so new. I have also read some not so good things about wal-mart gas. I guess it's about like everything else you get from there.

    ---------- Post added at 10:47 PM ---------- Previous post was at 10:45 PM ----------

    They are actually called Murphy USA. That is the gas station that has been put up in every Wal-Mart parking lot around here.

  7. #7
    Check to make sure your supercharger ose did not blow off.

  8. #8
    Rxpx guy's Avatar
    Join Date
    Apr 2011
    Location
    Monroe, La
    Posts
    20
    I looked in the engine compartment and everything looks intact.

  9. #9

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    Unless they had a bad batch. Or had some water in it. My GF's dad and whole family is convinced that places like gas city, speed way, and Dominicks have cheap quality gas compared to like BP. They said they used it a couple times and their v6 average boat and honda civic ran like crap on it. I was like yeah right gimme a break.

    Talked to my neighbor who has a super street chevelle with a blown 406 running approx 1100hp and he uses just normal premium gas city gas. So quality isnt a issue between stations. I wouldnt goto a ran down looking station but brand wise I dont care.

    try running it out of gas and refueling it again either at walmart or somewhere else just to make sure thats the problem. But if something else is wrong you might make the problem worse by riding it. JMO

  10. #10
    Rxpx guy's Avatar
    Join Date
    Apr 2011
    Location
    Monroe, La
    Posts
    20
    Yeah, thanks for the help. I used to work at a gasoline storage facility that stored just the pure gasoline with no additives like top end lube and all that other shit that goes in it. All of that gas went out to different gas stations as the same gas. What made it different was the additives the stations put in it after it got there. For the wal-mart stations to sell it so cheap, they have to be doing something crazy with it. Im almost willing to bet that is the problem. I ran all the gas out of it, well most of anyway, the last time I was out. Theres not enough in there to hurt anything when I fill back up cause it will be so diluted.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help, need the experts!! 2006 RXP Power Loss
    By tampa_m5 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 10-03-2016, 08:56 PM
  2. RIVA GAS POWER VALVE INSTALLATION INSTRUCTIONS.
    By RX951 in forum Yamaha How To & FAQs
    Replies: 24
    Last Post: 08-28-2013, 06:32 PM
  3. do gas power valves need waze eater clips
    By w-nut in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 11-02-2006, 02:02 PM
  4. Everything is cheaper at Wal-Mart
    By SuperJETT in forum Open Discussion
    Replies: 2
    Last Post: 09-01-2006, 06:12 PM
  5. Lost In Wal-Mart
    By elebouef in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 02-02-2006, 08:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •