Results 1 to 4 of 4
  1. #1

    Join Date
    Jun 2008
    Location
    Alabama
    Posts
    16

    GP1300 Backfiring after D-Plate..

    So I just got my 03 GP1300R back from the local Yamaha dealer. They did the throttle cable recall, rideplate recall, and I had them install a D-Plate while the exhaust was off. No sweat. So I picked it up Monday, and while still in the parking lot, we reved it, and it backfired and blew the exhaust hose loose, and filled the engine compartment with smoke.

    I left it there for three more days. They double clamped the exhaust, and assured me that it will not blow off again.

    So, my question is.....why the heck is it backfiring?? I understand that there is a different amount of backpressure now, but whats the deal.


  2. #2
    KamikazeGPR's Avatar
    Join Date
    Mar 2007
    Location
    Philadelphia
    Posts
    1,361
    +1
    99
    I had the same problem with my 03 after i took it in for the throttle cable recall, running rough and backfiring. I took it to TJ (inkaddict) he said when they re-installed the throttle body that it was cocked on an angle and sucking in air past the boots. He had it up and going in no-time.

  3. #3

    Join Date
    Jun 2008
    Location
    Alabama
    Posts
    16
    You are saying that it was pulling air passed the intake boots?

  4. #4
    KamikazeGPR's Avatar
    Join Date
    Mar 2007
    Location
    Philadelphia
    Posts
    1,361
    +1
    99
    That was my interpretation of what TJ told me. The mechanics at my local dealer at the time were retards. TJ has been lurking around here all day. Maybe he'll stop in and give more specifics of what he did to my ski to fix it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anybody Reusing Gaskets After D-Plate Install??
    By stepjl in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 09-17-2007, 05:24 AM
  2. Carb Adjustment After D-Plate Install????
    By stepjl in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-13-2007, 06:47 AM
  3. Loud Backfire After D Plate Install
    By GP1300r110 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-22-2007, 10:27 AM
  4. Bogging at around 5k rpm after D-Plate + Jetworks.
    By PuprleNuprleGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 08-08-2006, 01:44 PM
  5. New numbers after grate & plate bolt hole's filled
    By 97GPSLEEPER in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 07-24-2006, 08:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •