Results 1 to 3 of 3
  1. #1
    mjh3ides's Avatar
    Join Date
    Jul 2007
    Location
    Jupiter, Florida
    Posts
    6,805
    +1
    2,024

    Where are the L Temp & E Temp sensors located on a SHO Cruiser?

    My L Temp stopped working, & the other one I'm just curious where to find it. I couln't find anything in the service manual.


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    L temp is part of the speedo pickup and E temp is part of the compass.

  3. #3
    mjh3ides's Avatar
    Join Date
    Jul 2007
    Location
    Jupiter, Florida
    Posts
    6,805
    +1
    2,024
    Thanks beer man!! That makes sense. One of the last times I swapped plates I accidentally pinched the speedo wire & noticed it rubbed some of the insulation off. Must've got some water in it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 RXT where are the 30 amp fuses for charging system
    By race24x in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-03-2014, 09:42 AM
  2. Replies: 11
    Last Post: 09-11-2013, 01:29 PM
  3. Where are the grease fittings?
    By DeeGee in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-09-2006, 08:48 PM
  4. Where are the internal fuel filters?
    By ccassone in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 04-10-2006, 08:39 AM
  5. Where are the Riva numbers coming from?
    By Burnwater in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-05-2005, 02:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •