Results 1 to 9 of 9

Thread: Need help!!!

  1. #1

    Need help!!!

    Went the the lake today and when i got ready to start my rxp the digital screen would come on but there was no beep. Could this be a dead battery or what?


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Did the ski still start?

  3. #3
    no it beeped the first time I put the key in and after that it never beeped again and sometimes when you put the key in the display would not come on at all.

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Could be weak/dead battery. Have you run it recently?

  5. #5
    yup Ive had it out 4 times already and started right up everytime.

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Could be a bad dess post, or lanyard. Try your learner key.

  7. #7
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Sounds like a bad DESS post. Before the submergence, I had this issue. Test the battery first though.

  8. #8
    Hooked jumper cables up to it this morning and everytyhing worked like it should on the display but when i went to start it it would only turn over one time and nothing else.

  9. #9
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Take the plugs out and try to turn it over. Also, I would try and bridging your starter relay. That also might be the problem. Just a thought though.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new 05 RXT NEED HELP
    By RXPNJ in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-03-2009, 12:16 PM
  2. NEED HELP URGENT(HULK) RXP DOWN
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM
  3. My 2 RXP's need HELP!
    By Tube Master in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-19-2005, 09:44 PM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •