Results 1 to 4 of 4
  1. #1

    mfd keeps on busted fuse..

    been searching for this problem for years, what would the mfd cause to burnt fuse? could it be my trim motor? because im sure its not my stator coils... its new..


  2. #2
    Quote Originally Posted by andy95'slx780 View Post
    been searching for this problem for years, what would the mfd cause to burnt fuse? could it be my trim motor? because im sure its not my stator coils... its new..
    ok ok... mfd is gone... the neg. and positive supply of the mfd is already shorted... i don't know what happened, all i know for awhile mfd is good working and after riding for 30 to 40 minutes, mfd suddenly turned off, and 1st 1/4 fuse busted, i can't get a replacement only 1amp, so i replaced it, and again, busted.. now it keeps on busted fuse, looking for the short, and after i tested the neg and positive of the mfd, shorted already, my 3rd time mfd i bought

  3. #3
    urugol's Avatar
    Join Date
    Nov 2009
    Location
    Sydney, Australia
    Posts
    1,231
    +1
    3
    You possibly have a frayed cable somewhere. Having an electrical short in a jet ski is not a good thing, particularly with the gas fumes going on inside the hull. You really need to get to the bottom of this. I would pull the conduit that protects the harness and inspect all of the cables. I once had a short and traced it to the start/stop switch. There was a frayed cable that would short on the handlebars in there and when I hit the trim motor the mfd would go out. Also ensure you have a solid engine ground as well while you are at it.

  4. #4

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MFD keeps blowing fuses
    By brianstrange in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-30-2008, 02:12 PM
  2. Speeds keep on coming !!!
    By james k in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 10-26-2007, 10:30 PM
  3. MFD stays on ALL the time
    By anrkii in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-29-2007, 10:24 PM
  4. Takes a lick'n, keeps on tick'n
    By patmcf79 in forum Videos & Pictures
    Replies: 4
    Last Post: 01-30-2006, 11:13 PM
  5. Problem rxp keeps on shutting off
    By asiansurfer7285 in forum 4-Tec Performance
    Replies: 21
    Last Post: 12-12-2005, 11:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •