Results 1 to 8 of 8
  1. #1

    Unhappy 1996 Polaris SLT 780 - MFD Gauge Problems

    Hello all,
    I am new to site as I just bought my ski yesterday. I have a 1996 Polaris SLT 750. I was riding it from where I bought it back to my dock and the gauge cluster stopped working. Where should I start to look for the problem. It is low on fuel so the red warning light is on but the nothing in the cluster is working. Thanks for the help

    Kevin
    Last edited by K447; 04-27-2011 at 01:11 PM. Reason: SLT 780, not SLT 750


  2. #2
    thester71's Avatar
    Join Date
    Jun 2009
    Location
    central ma.
    Posts
    1,698
    Check the 1/4 amp fuse in the electric box

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by cvrs492 View Post
    Hello all,
    I am new to site as I just bought my ski yesterday. I have a 1996 Polaris SLT 750. I was riding it from where I bought it back to my dock and the gauge cluster stopped working. Where should I start to look for the problem. It is low on fuel so the red warning light is on but the nothing in the cluster is working. Thanks for the help

    Kevin
    Welcome to the Hulk

    If the red warning lamp is flashing, then the MFD does have power.

    Does (or did) the MFD display also actually show the words Low Fuel?

    Since the machine is new to you, spend some time reading up on the recommended maintenance and upgrades, and actually do them. Do the learning and maintenance FIRST, before you continue riding the machine. My signature links should get you going in the right direction.

    Electrical problems never get better by themselves. Take the time to clean up all the electrical connections at engine and battery, and look inside the electrical box. Always disconnect battery negative before working on the electrical system.

    Some MFD are sensitive to battery connect and disconnect. You can protect against that by unplugging the connector from the back of the display while messing with the electrical stuff. More info in the MFD section from my signature

    Also learn about the fuel sender float, which may need replacement.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Welcome to the Hulk Kevin.

    Your year or model you listed is wrong.

    You either have a 94 or 95 SLT 750

    Or you have a 96 SLT 780

    Do you have the round MFD or do you have the kinda oval-shaped one mounted in the handlebar pad?

  5. #5
    It was a typo on my part it is actually a SLT 780. I have the oval shape MFD mounted in the dash pad.

    It is actually at the lake I plan on going up Sunday morning when I get off work and cleaning it and doing the recommended maintenance on it at that time.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31

  7. #7
    Ok guys an update. I went over the ski and cleaned it up yesterday. I found out the fuel lines have been replaced. The ground wire is secure. I am going to check the compression next week when I go back down. What else should I be looking for as for the MFD I have wrote it off as broke it is not the fuse so I will just let it be.

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Check inside the elec box for any water, corrosion, loose, or broken wires.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris SLT 780 MFD Not Displaying RPM's?
    By mwenholz1 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-24-2012, 03:27 PM
  2. 1996 Polaris SLT 780 Owners Manual
    By rhislo in forum Polaris Classifieds
    Replies: 2
    Last Post: 04-05-2009, 11:37 PM
  3. 1996 Polaris SLT 700 mag cylinder problem
    By Hornby in forum Polaris Open Discussion
    Replies: 12
    Last Post: 03-01-2009, 11:27 PM
  4. Need Help! 1996 Polaris Slt 780 Mfd!
    By wjstewart in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 08-13-2008, 10:44 PM
  5. 1996 polaris slt 780 intermitant hesitation and low power,any ideas?
    By Fraser327 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-02-2007, 06:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •