Results 1 to 6 of 6
  1. #1
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109

    My battery has been dissconnected for months so...

    So again,im finishing up my 2004 rxp motor install and wanted to know if it was safer to go to the dealer and i have an unlimted access to the BUDS before i fire it up? im going there anyway to reset any parameters and zero out the idle control and reset the maint service timeline.Also can i expect the Compass,VTS thing to pop up too?

    thanks for the input


  2. #2
    Wheels-X's Avatar
    Join Date
    Apr 2011
    Location
    York, PA
    Posts
    45
    I'd fire it on the hose anyhow and see how it runs/ if you're having issues on the display and such. But if you're going there anyway firing it there for the first time wouldn't be a bad thing if they have good watercraft mechanics. Just have your purse handy.

  3. #3
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by sea-one View Post
    So again,im finishing up my 2004 rxp motor install and wanted to know if it was safer to go to the dealer and i have an unlimted access to the BUDS before i fire it up? im going there anyway to reset any parameters and zero out the idle control and reset the maint service timeline.Also can i expect the Compass,VTS thing to pop up too?

    thanks for the input
    look around for some "no vts" threads ,, some of them loose the vts after no battery for a while..
    in buds it will say its on ,but you will need to turn it off then back on (if my brains is right)

  4. #4
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    i can use the buds free, no purse needed,yea and a very confident,certified tech there too. long time buddy

  5. #5
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    You just answered your question bro. May as well get buds since it's free.

  6. #6
    Uh.. Is there something wrong with leaving your battery out? I have my battery out of the ski and indoors hooked up to a battery maintainer. Will I have to have my ski's computer reset or something now?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 15
    Last Post: 05-19-2015, 11:55 PM
  2. 2006 sea doo rxp has been sitting for 5 years
    By swervin33 in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 04-17-2014, 10:53 AM
  3. WTB - Parts WTB 05 ECU that has been reflashed for higher RPM
    By Avi8tor in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 09-05-2012, 06:06 PM
  4. 1996 waveblaster has been setting for 3 years????
    By markreef10 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-28-2012, 09:13 PM
  5. Replies: 2
    Last Post: 04-01-2008, 01:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •