Results 1 to 7 of 7
  1. #1

    Only 3000 rpm on my 2005 RXT

    Put in water for first time this season. Ski seemed to run well for first minute or so and then when I tried to get back on throttle it would only get about 3k rpm..then all of a sudden get a boost of power then back to same rpm. There are no codes being shown. Sounds like its missing too. I just limped back to slip. Anyone have this prob before?
    Last edited by MikeTrin; 05-08-2011 at 12:03 AM. Reason: testing out thread prefix SOLVED


  2. #2
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    Quote Originally Posted by kaorder1999 View Post
    Put in water for first time this season. Ski seemed to run well for first minute or so and then when I tried to get back on throttle it would only get about 3k rpm..then all of a sudden get a boost of power then back to same rpm. There are no codes being shown. Sounds like its missing too. I just limped back to slip. Anyone have this prob before?
    im having it now, turned out its a cracked injector. since its your first time riding this season, put in fresh plugs and fuel. see if that helps. pull your fuel rail and injectors to see if they spray correctly, if you are only running 3k they might be clogged enough to prove it.

  3. #3
    appreciate it!

  4. #4
    Project_X's Avatar
    Join Date
    Dec 2009
    Location
    Miami
    Posts
    162
    I had the same problem, it turned out to be bad plugs and old gas. change them out and you will see.

  5. #5
    thanks project x . Im hoping you are right.

  6. #6
    changed plugs today and it ran like a champ! Thanks all

  7. #7
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,592
    +1
    4,798
    Nice, I love a story with a happy ending...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Only 7500 rpm on 2010 RXT-X 260 with no errors codes
    By not2fast in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-03-2015, 08:14 PM
  2. How to install Wake Racks on my 2005 RXT
    By nsschwenk in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-02-2012, 03:01 PM
  3. Still having problem with power on my 2005 RXT
    By ndarimont in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-31-2011, 07:39 PM
  4. is there a grease fitting on my 2005 rxt
    By lost boyz in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-13-2010, 12:23 PM
  5. Help, having problems with my 2005 RXT, low hours
    By 05rxt in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-10-2006, 11:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •