Results 1 to 4 of 4
  1. #1
    em-dubya's Avatar
    Join Date
    May 2010
    Location
    Savannah, Ga
    Posts
    440
    +1
    7

    2000 Polaris Vitage starting problems.

    I have a 2000 Polaris Virage. I started it a few weeks ago, after buying a batttery charger since it was a litle low. I let it run for about 10 minutes then shut it off. Yesterday I tried starting it again and it will only make one single "clicking" sound and thats it.
    Anyone have any advice where i should go from here


  2. #2
    em-dubya's Avatar
    Join Date
    May 2010
    Location
    Savannah, Ga
    Posts
    440
    +1
    7
    The "click" sound comes from inside the electrical box

  3. #3
    Have you checked the battery voltage again? The battery it's most likely beyond "repair" by a charger and needs yto be replaced.



    Sent from my HTC Evo using Tapatalk

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,598
    +1
    1,276
    Quote Originally Posted by em-dubya View Post
    The "click" sound comes from inside the electrical box
    What is the battery voltage while you are holding the Start button?

    Without touching the Start button, can you turn the engine over by hand? This is done by grabbing the drive shaft coupler behind the engine and turning it. Remove the spark plugs to make it easier to turn the engine. If the cover is in place over the coupler you may need to remove it first.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris Service & Starting Problem - Need Help!
    By nuprin in forum Polaris Open Discussion
    Replies: 7
    Last Post: 10-02-2008, 02:58 PM
  2. 2000 Polaris 700 stalling problem
    By 2kids3pets in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-30-2008, 11:38 PM
  3. 2001 Polaris Virage starting problems
    By scotty771 in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 07-22-2008, 10:12 PM
  4. Polaris Virage Starting Problems...
    By Goliath in forum Polaris Open Discussion
    Replies: 14
    Last Post: 06-21-2008, 09:32 AM
  5. 2000 Virage strange starting problem
    By bclake in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 09-08-2007, 04:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •