Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    trofodotiki's Avatar
    Join Date
    Feb 2011
    Location
    Athens Greece
    Posts
    101
    +1
    1

    Check Engine light and performance issues Rxp Stage 3

    Hello, and thanks for the advice on my last post! If any of this is a repeat and has been answered, please just post the link for me..

    Anyway, i bought a used 04 Rxp stage 3 (i believe) and have a few issues.

    When ridding randomly the red light flashes and the check engine appears on the screen, this can happen 10 seconds after a cold start, or 20 minutes into a cruze and stays on for a few seconds to a few minutes. The dealer says not to worry and that they cant plug it into the computer to check the codes because i have a Rotax racing Ecu. I dont believe them, that everything is fine and want your advice. I have tried the trick to get the code, but all it displays is the SeaDoo text.

    Please tell me if something is wrong because of performance i am getting here. I just installed a new fizzle style intercooler, and groco filter, everything is clean and right from what i can see. My ski has the Ecu in the picture, a gen two supercharger wheel (Jerry just serviced it for me), riva front intake, and worx sponsoons,straight through exhaust with moded stock can, oil level right, the injectors are they are Delphi 50 lb./hr. I dont know about the jet parts, there is a picture of the grate if someone can tell me what it is..

    Here is what i got from the GPS:
    68.1mph on a flat lake, and 8150Rpm, 2 mph headwind, full fuel, 460 lbs me and my wife, and 30 lbs cargo in front. Does that sound right?

    Also i thought with this Ecu you needed, injectors, fuel pump and regulator, but from what i can see the fuel pump is stock and no external regulator.
    I also want to make sure i have the cooler thermostat, is there any way to tell, appart from taking it appart?
    There is a metal ring in place of the carbon seal, with a zerk fitting looks like a RAD4, which i start the engine and pump grease into until is comes out around the shaft in the ski, i am using the pink flamingo grease(well...it is florida, and thats what was recommended locally..) am i doing the right thing?Maybe i need a special grease?

    Finally i have a left over Rotax Racing Intercooler, pressure tested to 35psi and fine, can you tell me what a fair price is to sell it for?

    Regards Rafael.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0120.JPG 
Views:	97 
Size:	187.1 KB 
ID:	237548   Click image for larger version. 

Name:	IMG_0119.JPG 
Views:	80 
Size:	198.9 KB 
ID:	237549   Click image for larger version. 

Name:	IMG_0122.JPG 
Views:	72 
Size:	264.4 KB 
ID:	237550   Click image for larger version. 

Name:	IMAG0689.jpg 
Views:	77 
Size:	98.8 KB 
ID:	237551  


  2. #2
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    You should find out what injectors you have and the rev limit of that ecu. Its gonna be 8600 or 8800 and your only turning 8150. Thats some of your problem. What prop are you running with that

  3. #3
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    if you hit the set button 5 times it should give a code on why the red light is on.

  4. #4
    trofodotiki's Avatar
    Join Date
    Feb 2011
    Location
    Athens Greece
    Posts
    101
    +1
    1
    Quote Originally Posted by GOLD06RXP View Post
    You should find out what injectors you have and the rev limit of that ecu. Its gonna be 8600 or 8800 and your only turning 8150. Thats some of your problem. What prop are you running with that
    The injectors and half black, half military green, i dont know how else to find out what they are(any advice welcome)
    I also dont know what prop it has on right now...
    And the Ecu rev limit i dont know, thats why i posted a pic of the stickers on it so someone can tell me what it is...
    I had a feeling is should be revving higher, but cant find whats stopping from so...

    ---------- Post added at 10:10 AM ---------- Previous post was at 10:09 AM ----------

    Quote Originally Posted by mrbtd View Post
    if you hit the set button 5 times it should give a code on why the red light is on.
    I did do that, when it was happening, and now, and all it says is END, and gives me the Sea-Doo logo...

  5. #5
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Quit riding it until you can learn what you have. Nothing but bad can come from it. Could be a simple problem but you need to get to know that ski from top to bottom.

  6. #6
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    Quote Originally Posted by mrbtd View Post
    Quit riding it until you can learn what you have. Nothing but bad can come from it. Could be a simple problem but you need to get to know that ski from top to bottom.
    +1, do you still have the seller's contact info or email? may just want to ask if he knows what parts they are or can point you in the right direction.

  7. #7
    RXP rider's Avatar
    Join Date
    May 2010
    Location
    Northern Europe
    Posts
    125
    You need to talk to Malte @ mrracing about that ecu, he will tell you what is is mapped for.
    Take a look at your injectores there should be a number on them to indifying them.

  8. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Rpm issue could be if you have the knock sensor piggy back adapter installed. It should not with that ECU.
    Also Prop size, and SC slip can cause the low RPM issues. You should be at 8450 (at least) with that ECU, which hopefully they already installed up graded valves, and lightened retainers before you have valve issues.

  9. #9
    trofodotiki's Avatar
    Join Date
    Feb 2011
    Location
    Athens Greece
    Posts
    101
    +1
    1
    Quote Originally Posted by mrbtd View Post
    Quit riding it until you can learn what you have. Nothing but bad can come from it. Could be a simple problem but you need to get to know that ski from top to bottom.
    My thinking also, when i bought the ski, I got from a dealer, who dint know anything about it, said everything is fine just ride it. Instead i took ALL the pipping out until only the engine was left...To learn it inside out. THe only thing i havent done yet is the jet part, which i have ordered the jet grease so i can do that as well...

    ---------- Post added at 06:06 PM ---------- Previous post was at 06:04 PM ----------

    Quote Originally Posted by sHALlow View Post
    +1, do you still have the seller's contact info or email? may just want to ask if he knows what parts they are or can point you in the right direction.
    I know it sucks, i got it from a dealer, and the contact info they had for the previous owner is no longer valid, they dint even know it had an Ecu in it, the guy the mechanic here DID NOT EVEN know that it uses a water/air intercooler...I mean how can these people be trusted, at least you guys are around!

    ---------- Post added at 06:09 PM ---------- Previous post was at 06:06 PM ----------

    Quote Originally Posted by psycho rxp View Post
    Rpm issue could be if you have the knock sensor piggy back adapter installed. It should not with that ECU.
    Also Prop size, and SC slip can cause the low RPM issues. You should be at 8450 (at least) with that ECU, which hopefully they already installed up graded valves, and lightened retainers before you have valve issues.
    I know this is a newer engine, it was overhauled just 20 hours ago, i have riden the ski for 6 hours, Jerry took care of my Sc for slip and it had the metal washers in it... How can i remove the piggy back sensor?

    ---------- Post added at 06:23 PM ---------- Previous post was at 06:09 PM ----------

    Ok guys i found out what the injectors are they are Delphi 50 lb./hr.. Is there supposed to be an upgraded fuel pump on this ski? I havent taken appart the fuel pump, but it looks stock on the outside...

  10. #10
    trofodotiki's Avatar
    Join Date
    Feb 2011
    Location
    Athens Greece
    Posts
    101
    +1
    1
    Can anyone tell me what the rev limiter is on this ECU?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Check Engine light and message, led tool issues? VIDEO FIXED!
    By fastlane in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-15-2014, 12:19 PM
  2. Out for a ride...Check engine light and codes..
    By Urwheelman in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-29-2012, 09:40 PM
  3. 2002 Genesis i Check Engine Light and low RPM
    By waterhead in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 06-28-2011, 08:14 AM
  4. check engine light and error code P0351
    By cawky in forum 4-Tec Performance
    Replies: 16
    Last Post: 03-27-2009, 09:21 PM
  5. Check engine light and msg but no codE?
    By camar0 in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-15-2008, 03:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •