Results 1 to 9 of 9
  1. #1

    rxp-x stock cooler question/help...is it broke?

    I was doing some upgrades this spring,i pulled stock intercooler out,etc, changed to viton seal in supercharger, cleaned out stock cooler with gas. Anyway, when i pulled my hoses off the x- cooler, i had water in there??? I thought what the hell!! Did it freeze and break (first thought) I winterized,etc (of course) its garage kept (not heated)
    I took it out, plugged holes, blew on it, No leakage. (lung pressure,lol)

    Got reading, that these things swell and break. Everything was stock last year (bought it new last summer)
    Wondering if mine broke/cracked?? I haven't had any running issues last year, ran great. No signs of water intrusion.
    I believe i have about 30 hours on it.

    It was way more water, than just from condensation, i dumped out about a cup of water

    Is there a way to double check to see if its leaking, before i run it again?
    I just don't want bigger problems down road.
    will running on the hose show leakage?
    I pulled the hoses off our rxt-x, has about 8 hours on it, dry as a bone!


  2. #2
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,061
    +1
    790
    On my House water hose I get about 50p.s.i water pressure out of my garden hose.
    With that being said I just have a section of garden hose I connect to the inlet water side of the ic and then I use anothere hose and a valve on the exit side. I then turn the water on and bleed the air out of the IC and then I sit it for 30mins with papper towles in the end tanks. If and when I check after 30mins and there papper towels are wet. Well then I know I have a leak. Oh yea I plug the bleed line on a X IC.
    Hope this helps.

  3. #3
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Common problem with those ics. Do you have any warranty left?

  4. #4
    yeah, i have the 4 year warranty, just hate dinking with them. Stupid potlicker dealer,took ski in once and told them something happen,they lied about a bunch of stuff and gave excuses,big ole pile of BS...then i happened again and all it was, was a superchager hose come off. when they kept my ski for a week to "diagnose the problem"PFFF.
    Where i can get different cooler (if that is the problem) and something major happens,put stock one back in and tell them its fubar. lol

  5. #5
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Im not sure with the stock bracketry that use can use a different cooler bro.

  6. #6
    i'll pull it out again and do the water hose thing (thats good idea) and see what becomes of it. If its leaking, maybe i'll order a reloaction kit or something and just keep that stock stuff, in case there is a Huge problem. If its leaking, i have to keep a eye on the wifes ski too.

  7. #7
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    If your ski starts running rough/sputtering etc it's prob leaking bro.

  8. #8
    thats whats wierd, its never sputtered or ran rough, except when supercharger hose came off, which was mid summer, ran All rest of summer another good 10+ hours and ran great.
    I can't figure how else it could get water in there? condensation, maybe some came thru stock breather and it sat in there? Seems like it would have sputtered if i did suck some up. I seen styrofaom in there. lol

  9. #9
    Ok, pulled it out this evening. plugged holes,etc...put the hose to it 50 psi water pressure. Not a single drop of water in there. So....i'll run it, if a get a little sputter, i know whats going on.
    thanks for the info and idea too. I could also take it the park where we stay, water pressure there is 80 psi. lol

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2009 RXP 7540 RPM Slippage Good- What is it?
    By wingsaircharter in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-21-2016, 11:26 AM
  2. Replies: 3
    Last Post: 08-24-2015, 02:06 AM
  3. 2008 RXP-X Wire HARNESS QUESTION ...Help!
    By edsun1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 12-11-2014, 06:04 PM
  4. What is it with the stock Solas 15/20R and the RR ECU?
    By Jarrett in forum 4-Tec Performance
    Replies: 14
    Last Post: 04-24-2006, 03:37 PM
  5. Clutch question, I think it went? help
    By Griff350 in forum 4-Tec Performance
    Replies: 13
    Last Post: 01-08-2006, 06:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •