Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,061
    +1
    790

    ECU programming again? Dealer could not do it. SO please advise..

    Guys I have Ray sundances RXTx here at my house and we are tring to put a stock X ECU back in it and we are having all sorts of issue's. I asked before and you guys suggested I go to the dealer and have them reprogram it back on the ski...

    Well after 2 hours at the dealer we have nothing and nothing was acomplished, so I need you guys help.

    It keeps showing a CPS code and will not start. dealer has programmed the ECU to gauge cluster and still no worky...

    I put the RIva back in and It starts with no issue. SO what the hell are they doing incorrectly? Any help would be great..

    Also he kept pulling the stuff off of the riva ecu to wright onto the stock X and back and forth and nothing... I sure hope they can't fung up the Riva...

    Anyway any help would be greatly appreciated and I would even send it all off to one of you buds candoo gurus to get it correct. Gauge TB and ECU what ever you needed to make it right...Will pay you for services of system for sure?

    Or Buy a X ECU and Gauge that work togethere?

    Please help


  2. #2
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    its been a while since I changed out a ecu but I think I had to program the ecu to the mempem then it accepted the gauge cluster then reset the TPS ?
    but dont quote me on it as I may be off here
    all I remember is lots of putting the key on pulling the key off.

    ---------- Post added at 07:56 AM ---------- Previous post was at 07:54 AM ----------

    actually that was with a 05 so different set up !

  3. #3
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,061
    +1
    790
    Would you entertain setting for me?

    Soups never mind to much shipping

  4. #4

    Join Date
    Jul 2005
    Location
    Lake Dunlap, Texas
    Posts
    1,599
    +1
    28
    Austin--I am at a loss as to whats up. I know the stock ECU you are trying to get to work is not from my RXT-X. Maybe there
    is an issure with the one you are trying to program to work. If any of you guys out there have any ideas please chime in. Thanks,--Ray

    P.S. Steven (Skoepp Do you still have the stock ECU which came off this boat??

  5. #5
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,061
    +1
    790
    COme on guys out of 65+ views I know someone that knows the answer can help...

    What the heck are they doing wrong???

    Is this normal to swapping ECU's?


    I even said I would pay one of you to do it...... Money doesn't talk anymore?

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Shoot Dennis at Candoo a message im sure he will help. I would help but my 08 setup is not ready yet..

  7. #7
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,061
    +1
    790
    Quote Originally Posted by beerdart View Post
    Shoot Dennis at Candoo a message im sure he will help. I would help but my 08 setup is not ready yet..
    Thanks my friend I will hit him up.

  8. #8
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    Quote Originally Posted by Water4fire View Post
    Would you entertain setting for me?

    Soups never mind to much shipping
    what year cluster/ski? what year ecu Part number? is It a early 09 ecu to a 10 ski ?

  9. #9
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,061
    +1
    790
    Quote Originally Posted by jaffabas View Post
    what year cluster/ski? what year ecu Part number? is It a early 09 ecu to a 10 ski ?

    2008 rxt-x AND A 2008 rxt-X ECU (OFF OF ANOTHERE SKI) CONFIRMED BY ppg x ECU


    It keeps giving a CPS error code.... And will not start the boat.

    BUT the RIvas Will and ofcoarse has run the boat 100 hours no issue's so why stock throws a CPS codes I have no clue besides dealer doesn't know what he is doing.

  10. #10

    Part Numbers

    Let me ask some questions to get all the facts first

    • What is the exact fault code? You get with the OEM ECU
    • What is the part number for the OEM ECU
    • What is the part number for the Riva ECU
    • What is the part number for the Cluster
    The ECU part number is centered and at the top of the label.


    Also on 2006+ when changing the ECU you need to do the following...
    • Marry the Cluster to the ECU (if required, sometimes they match)
    • Set the TPS

    If you change the Cluster you need to
    • Marry the Cluster to the ECU (if required, sometimes they match)
    • Make sure Cluster has the proper flash loaded if it's the replacement part number now used

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 virage, could not get it to run! will part out
    By Alex3012red in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 12-29-2010, 07:16 PM
  2. 2009 260x First Oil Change...Dealer or Do it yourself???
    By KWO in forum Kawasaki PWC Performance (4-stroke)
    Replies: 16
    Last Post: 08-22-2010, 10:53 PM
  3. Replies: 7
    Last Post: 12-26-2008, 04:07 PM
  4. Replies: 35
    Last Post: 10-22-2008, 11:09 PM
  5. should if do it ( rr ecu)
    By kkgregs in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 12-12-2006, 04:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •