Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    06 gpr trim is seized up. What should i look at next

    Ok so i have a 06 gp1300r. I bought it and the trim was seized up. It dose not move at all. I took the grip apart and greased the bearings and then tried it again and nothing different. I then took it off again and detached the cables from it and tried pulling on them wach and neither would move at all. What should i check next?


    Any help would be great.
    Thanks
    Kevin


  2. #2
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by pulser9 View Post
    Ok so i have a 06 gp1300r. I bought it and the trim was seized up. It dose not move at all. I took the grip apart and greased the bearings and then tried it again and nothing different. I then took it off again and detached the cables from it and tried pulling on them wach and neither would move at all. What should i check next?


    Any help would be great.
    Thanks
    Kevin
    its probably the top cables from the grip to the pivot

    disconnect the top cables from the pivot piece and see if they move... if they do, try to manually move the rear cable

  3. #3
    thanks ill try that tonight

  4. #4
    can someone give me a idea of where the pivot peice is. Im guessing its up front but i cant trace the line down my arms are to fat to get in there.

  5. #5
    Quote Originally Posted by pulser9 View Post
    can someone give me a idea of where the pivot peice is. Im guessing its up front but i cant trace the line down my arms are to fat to get in there.
    open up the hood/visor, remove the bucket, look in and to the left of the ski, it is mounted on the inner hull...
    see pic...
    mine has a dif cable set up, but yours is similar and this is where it is at...

  6. #6
    haha shit i was hopeing that i wouldn't have to open up the visor to get to it beacause mine is stuck and wont open. The button wont push down. Looks like ill have to figure that out first.

  7. #7
    Quote Originally Posted by pulser9 View Post
    haha shit i was hopeing that i wouldn't have to open up the visor to get to it beacause mine is stuck and wont open. The button wont push down. Looks like ill have to figure that out first.
    wow!, is this a salt water ski? pushing down on the visor doesn`t help release the latch?

  8. #8
    yea the ski is used half salt water and half fresh but there really isnt any corrosion on stuff. I got the hood to come up tho. It must have been seated wrong because now it works perfect. I took the cables off the pivot and pulled them out and they are seized up. The ski sat for over a year and a half when my buddy was away in the military without being touched so i think that may account for it. i stood them up and driped oil down them and redid this a few times as it went down hopfully if they sit a little while they will break free. If not i guess i will have to see how much they are new or see if i can find some used ones.

  9. #9
    Quote Originally Posted by pulser9 View Post
    yea the ski is used half salt water and half fresh but there really isnt any corrosion on stuff. I got the hood to come up tho. It must have been seated wrong because now it works perfect. I took the cables off the pivot and pulled them out and they are seized up. The ski sat for over a year and a half when my buddy was away in the military without being touched so i think that may account for it. i stood them up and driped oil down them and redid this a few times as it went down hopfully if they sit a little while they will break free. If not i guess i will have to see how much they are new or see if i can find some used ones.
    sounds hokey but you can try this to: get a plastic baggie for each cable, poke a hole in the corner, stick the cable in the hole, wrap a rubber band around the cable sheathing tightly, pour oil, or lube in the bag, tie it up with string or something and hang in the garage or wherever you can, place something under them so they don`t make a total mess...

  10. #10
    did what you said and ended up being able to break the cables free. Got everything working perfect.

    thanks for your help guys

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Picking up a built 2006 RXP215. What should I look for?
    By mack verde in forum Sea Doo Open Discussion
    Replies: 28
    Last Post: 05-18-2015, 10:05 PM
  2. Help..front Super Charger bolt is seized up..
    By ashnic in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-02-2014, 09:12 PM
  3. Replies: 7
    Last Post: 04-01-2014, 08:12 AM
  4. Replies: 7
    Last Post: 08-15-2011, 12:29 PM
  5. Is this my wear ring? What should it look like?
    By bmc1818 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 06-28-2010, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •