Results 1 to 2 of 2

Thread: Primer problems

  1. #1

    Primer problems

    I have a js550, rebuilt the whole engine last yr, it fires up when i put a lil fuel in the carb and it will run, but when i try to use the primer to dump fuel in it i get nothing to the carb...does this mean my primer is no good...? Im kinda new at this so any help would be great, thanks


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,006
    +1
    281
    You should be able to feel the primer moving fuel, as well as possibly hearing it spray. Keep in mind that it may take a dozen or more pumps to get fuel into the primer. Is your hose translucent? If so, you should be able to see the fuel moving in it. If you installed the primer fittings in place of the choke shaft, take the flame arrestor off and watch it spray.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Primer pumps problem
    By rideryamaha in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-11-2014, 09:42 PM
  2. Primer problems
    By Budman in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 03-01-2010, 07:58 AM
  3. Troubleshooting the Rotax Racing Stage I kit (was problems)
    By Jarrett in forum 4-Tec Performance
    Replies: 104
    Last Post: 10-22-2005, 08:12 PM
  4. Mysterious problem on my RXP
    By Jeff C in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-13-2005, 10:08 AM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •