Results 1 to 4 of 4
  1. #1
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7

    Magneto or battery

    Can't seem to hold a charge. How do I tell if the magneto is bad? Do they need to be replaced when the engine gets water locked? Got the engine rebuilt and put it in another ski. Battery was fine before the flood. How do I tell which is the issue. I have to jump the ski to start it. Reads 9.62 v while off. It shows 13.62 running


  2. #2

    Join Date
    Feb 2011
    Location
    Canton, GA
    Posts
    103
    Quote Originally Posted by MSRXP View Post
    Can't seem to hold a charge. How do I tell if the magneto is bad? Do they need to be replaced when the engine gets water locked? Got the engine rebuilt and put it in another ski. Battery was fine before the flood. How do I tell which is the issue. I have to jump the ski to start it. Reads 9.62 v while off. It shows 13.62 running
    imo its the battery because if you have a full charge on the battery and its only reading 9.62v when it should be about 12.5v or so, and then when you jump it it reads 13.62 which is what it should be that tells me that the magneto is working but theres a dead cell in the battery which is why you have to jump it..i could be wrong wont be the first time ,but i would start with replacing the battery..to double check u could go to advance auto parts and have them check the battery..

  3. #3
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by BIG E View Post
    imo its the battery because if you have a full charge on the battery and its only reading 9.62v when it should be about 12.5v or so, and then when you jump it it reads 13.62 which is what it should be that tells me that the magneto is working but theres a dead cell in the battery which is why you have to jump it..i could be wrong wont be the first time ,but i would start with replacing the battery..to double check u could go to advance auto parts and have them check the battery..
    That's kinda what I was thinking. Just wanted a verification before I coughed up 80 bucks for the battery. Thanks!!!!

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    could be the rectifier

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Starter, Battery or Wiring?
    By kingstretch in forum Yamaha Old School Skis
    Replies: 20
    Last Post: 08-25-2008, 08:36 AM
  2. Replies: 7
    Last Post: 07-15-2008, 02:37 PM
  3. Dry cell or wet cell battery.
    By bruinsrme in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-30-2007, 07:21 PM
  4. Battery tender and/or upgrade??
    By Djames in forum Sea Doo Sport Boats
    Replies: 6
    Last Post: 08-24-2007, 09:04 AM
  5. Battery Packs, Good or Bad?
    By 4stroker in forum Polaris Open Discussion
    Replies: 49
    Last Post: 05-14-2007, 12:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •