Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    96 spx hard start

    Hey guys , Bought a clean low hour 96 spx at the end of last summer . The ski ran great but had some cavitation so I replaced the wear ring and rebuilt the pump ;while I was at it knowing about the grey fuel line I went ahead and replaced all of the lines and cleaned the entire fuel system and completely rebuilt the carbs . I left no stone unturned . The carbs are set back to specs at 1 1/4 low and 0 on high . My issue is the ski runs fine but is difficult to start like it it is way rich on the bottom. I have done a plug chop at wot and they look good but have not checked low end . My riding partner said this is just a trait of the dual carb spx and is no big deal. I am told that the 1 1/4 setting can be variable . It also has a slight hesitation from a dead stop like to much fuel. My question is will it be safe to go in on the low speed to try and clear this up or should I leave the mix alone and look elsewhere.


  2. #2
    20 feet Boy's Avatar
    Join Date
    Jul 2010
    Location
    Bend OR
    Posts
    1,257
    +1
    1
    My seadoo did the same thing and it turn out to be, to much of a gap between the rotary cover. I think my rotary valve cover was wet sanded to much and fuel was jumping back in forth between cylinder. Making it not idle and hard to start. When I took it a part the rotary valve was warp. So I got a new one and a recondition cover and fixes it. If your ski was rebuilt it might have grooves on rotary valve cover. This will do the same thing. I don't known if this is your problem. Airbornexp is the guy who help me. He will most likely, chime in. Good luck

  3. #3
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    IMO, if you live in an area where ethanol fuel is used,then i would open them up a bit more as it takes more fuel to run,kinda like alcohol but not as much.again guys,jmo

  4. #4
    Thanks for the input; A friend had mentioned something about the rotary plate and a seal. I will look further into . I am able to get fuel without ethenol until june .

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,772
    +1
    129
    I would look down the throat of the carbs while trying to start and see if fuel is pouring in. Sounds like a typical leaky needle and seat assembly to me. You might also try trimming back the plug wires a hair, maybe it's not getting a real good spark at low rpm.

  6. #6
    Completely rebuilt the carbs with new needle and seat and trimmed wires back . It runs awsome and will jump right on plane it is just the starting issue . It dose it every time you kill it hot or cold same results. I have to hold the throttle to the grip to start it only takes about three seconds maybe four at the most. Once it starts it burbles as in to much fuel for a second then clears up and its fine. I have owned 1994 polaris sl650 , 95 waverunner 3 , 99 kawasaki stx1100 and have never had this issue. I know it is something simple . thanks for the replies.

  7. #7
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    needle and seats need replaced

  8. #8
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,772
    +1
    129
    Try pulling the return line off while cranking or running and see how much fuel is coming out. Sometimes a little trash will plug off the small return line restrictor on the carb and it's easily overlooked. If it's plugged the fuel system builds too much pressure and floods.

  9. #9
    I wll look at that in the morning. I know even though I cleaned rebuilt the carbs and put all new fuel line . That is a very small orfice and it wouldnt take much to do that.

  10. #10
    Yes , that was the first thing I did. The needle and seat that is. I

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 HX Hard Starting and Doesn't REV up very fast?
    By shkdwn387 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 03-22-2012, 08:14 PM
  2. 1997 SPX hard start and sluggish
    By Andrerichard in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-23-2009, 07:57 PM
  3. 96' SPX start issues. Please help!
    By goBENGALS in forum 2-Stroke Performance
    Replies: 1
    Last Post: 11-02-2008, 08:01 AM
  4. 96 xp hard start in water.
    By 99wrangler in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-15-2008, 06:24 AM
  5. 96 SLX780 Rough Idle, Hard Start, and Miss
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 23
    Last Post: 02-27-2008, 06:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •