Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    YoCoLifSavr's Avatar
    Join Date
    May 2010
    Location
    East Coast, Virginia
    Posts
    74

    Lightbulb 2000 Seadoo GTI WOT Issue - Acting like it has a rev limiter?

    Hey guy's I just bought myself a 2000 Seadoo GTI. I got a really good deal on it. It was a little dirty but I got it all cleaned up and it looks great. Before I brought it home I did the usual start up and run. Checked compression and it was between 145-150 on both cylinders. It fired right up no problem. The fuel gauge works fine and I didnt hear any knocks or anything coming from the motor. Here is a pic of the ski that I took today...
    Click image for larger version. 

Name:	img8283a.jpg 
Views:	3285 
Size:	224.4 KB 
ID:	238578

    Anyways I fired it up today and everything was ok until I pegged it WOT. It seemed like it had a rev limiter. This is my first Seadoo so I am not familiar with these as far as how they run out of the water on the hose etc. I have owned Kawasaki and Polaris ski's so im new to the Seadoo's. The fuel lines have been replaced also cause im sure that will be a question ya'll ask. The gray lines are gone. I have attached a video for you all to hear. Dont mind the quality. Is anyone else hearing what im hearing? To me it seems like the throttle isnt spooling up to full tilit and is acting like it is being limited. You can also see that I dont even get the throttle switch all the way down before the throttle is limited. Anyone have any advice? Thanks so much! Here is the video.




  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    It does have a rev limiter. And you where hitting it.

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    It does have a rev limiter. And you where hitting it.

    oops double post

  4. #4
    YoCoLifSavr's Avatar
    Join Date
    May 2010
    Location
    East Coast, Virginia
    Posts
    74
    Well then I am going to be taking it out tomorrow to test run it and see how she does. Thanks for the info. What RPM does it typically limit at? There is no way to tell cause their isnt an RPM gauge.

  5. #5
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    yea but did you see that he's barely on the throttle?it gets there quick. i don't know,... seems weird. true test will be on the water

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Not sure what the limit is. I am thinking some where around 7000.
    There are some very good SD 2 stroke people here. Someone will prob chime in.

  7. #7
    YoCoLifSavr's Avatar
    Join Date
    May 2010
    Location
    East Coast, Virginia
    Posts
    74
    Quote Originally Posted by sea-one View Post
    yea but did you see that he's barely on the throttle?it gets there quick. i don't know,... seems weird. true test will be on the water
    See thats what I thought too, maybe an adjustment on the throttle lever? Not sure, just didnt want to waste time hooking up and putting in the water if there was something wrong.

  8. #8
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    will it idle steady?

  9. #9
    YoCoLifSavr's Avatar
    Join Date
    May 2010
    Location
    East Coast, Virginia
    Posts
    74
    Yes it idles fine...no problems there.

  10. #10
    YoCoLifSavr's Avatar
    Join Date
    May 2010
    Location
    East Coast, Virginia
    Posts
    74
    I uploaded the other video I had and added it to the main post. I think the first video was just a bad video for you to see. Maybe this 2nd one will help a little more. To me it sounds like a limiter but I wanted to make sure from one you guys that has Seadoo knowledge

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 seadoo gtx acting like its slipping
    By 97GTX in forum Open Discussion
    Replies: 10
    Last Post: 07-25-2016, 07:48 AM
  2. 2003 seadoo gti rfi issue
    By Ladykarter in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-17-2013, 04:37 AM
  3. 96 SLTX acts like it is going into limp mode after it warms up
    By Rocko8338 in forum Polaris Open Discussion
    Replies: 34
    Last Post: 06-21-2012, 11:20 PM
  4. Seadoo GTI Starting issues
    By impulsive in forum 2-Stroke Performance
    Replies: 4
    Last Post: 04-07-2012, 06:52 AM
  5. 2001 Seadoo GTI starting issue
    By leedanger in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-31-2011, 07:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •