Results 1 to 6 of 6
  1. #1

    2000 Gp1200r HELPPP PLEASEEE!!!!!

    Hey I have been lurking the forums for a few days here and I need help asap. I was given a gp1200r for free and previously owning a 1300r I jumped all over the chance to take the ski. I know the impeller is pretty locked up the crabs need to be cleaned and the ski is in somewhat rough shape. It was left outside a good portion of the time and the seat is totally shot. I started to take the ski apart to try and figure ot what is going on with it.
    I took the pipe off and the airbox next to the crabs. I tried taking the rear pump assembly off but the shaft seems to be stuck and really grinds when trying to turn the ski over. The motor will crank but it is spraying what looks like a sh!t ton of water out. The compression is 150 @1 and 3 and 140 @2. Does anyone have any idea what could be going on and why it seems to be spraying water out of the cyclinders and how to diagnos the issue. I can do most of the work myself please let me know your thoughts.


  2. #2
    whip the head off right away if there is water I suggest you dry it best you can or blow it out with compressed air and spray some oil all over that poor motor before you seize it for good

  3. #3
    Thanks for the input. My only concern is it seems to be cranking fine its just spitting a ton of what we believe to be water out of the cylinders. The previous owner said it never got submerged and that it just sat outside for long periods of time. Could this cause water to get into the cylinders?

  4. #4
    TX21's Avatar
    Join Date
    May 2007
    Location
    North Texas
    Posts
    988
    +1
    7
    Quote Originally Posted by hockeyrider03 View Post
    Hey I have been lurking the forums for a few days here and I need help asap. I was given a gp1200r for free and previously owning a 1300r I jumped all over the chance to take the ski. I know the impeller is pretty locked up the crabs need to be cleaned and the ski is in somewhat rough shape. It was left outside a good portion of the time and the seat is totally shot. I started to take the ski apart to try and figure ot what is going on with it.
    I took the pipe off and the airbox next to the crabs. I tried taking the rear pump assembly off but the shaft seems to be stuck and really grinds when trying to turn the ski over. The motor will crank but it is spraying what looks like a sh!t ton of water out. The compression is 150 @1 and 3 and 140 @2. Does anyone have any idea what could be going on and why it seems to be spraying water out of the cyclinders and how to diagnos the issue. I can do most of the work myself please let me know your thoughts.
    Sounds like a lot of work if the motor is full of water and has been sitting. Its going to be a rust bucket.

  5. #5
    salvage and good bits off, sell them and put a 4-tec turbo motor in

  6. #6
    ski is up and running need a carb rebuild kit and seem to be good to go. Everything was pulled apart and checked and cleaned from water damage.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Intermediate shaft from 2000 gp1200r
    By wademcgee in forum Yamaha Classifieds
    Replies: 1
    Last Post: 06-24-2008, 08:14 PM
  2. Advice needed... buying a 2000 gp1200r...
    By jcc011185 in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 07-13-2007, 04:36 PM
  3. 2000 gp1200r
    By TX21 in forum Yamaha How To & FAQs
    Replies: 14
    Last Post: 05-22-2007, 08:22 AM
  4. Price help on a 2000 GP1200R
    By flnsx in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 05-15-2007, 05:30 PM
  5. I need an oil pump for 2000 GP1200R
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 04-29-2007, 11:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •