Results 1 to 9 of 9
  1. #1
    trofodotiki's Avatar
    Join Date
    Feb 2011
    Location
    Athens Greece
    Posts
    101
    +1
    1

    Water in the Jet Cone?

    I took appart the pump to change the grease and found that it had perhaps 7-8 drops of water in the cone... The O rings are good and there seems to be no other damage...
    Is that normal? First time of it being taken appart since i bought the RXP used..
    How do you know if the roller bearing is bad?

    I am also going to put Royal Purple High Performance gear oil in there 75W-140 sounds like a good choice of oil?


  2. #2
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    What colour is the grease? If real dark blackish pump needs looking at I believe.

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Ive used Royal Purple in my pumps with no issues..I would have a look at it though, you dont want to put gear oil in there and have it blow out or take in water do to a bad front seals

  4. #4
    trofodotiki's Avatar
    Join Date
    Feb 2011
    Location
    Athens Greece
    Posts
    101
    +1
    1
    Quote Originally Posted by Sayers View Post
    What colour is the grease? If real dark blackish pump needs looking at I believe.
    Yeah the front part of the grease was blackish-grey...

  5. #5
    trofodotiki's Avatar
    Join Date
    Feb 2011
    Location
    Athens Greece
    Posts
    101
    +1
    1
    Quote Originally Posted by Snoman View Post
    Ive used Royal Purple in my pumps with no issues..I would have a look at it though, you dont want to put gear oil in there and have it blow out or take in water do to a bad front seals
    I would like to take a look at the seals in front for sure..Is there a How-To on this? How about vitton seals on it or upgraded ones....?

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by trofodotiki View Post
    I would like to take a look at the seals in front for sure..Is there a How-To on this? How about vitton seals on it or upgraded ones....?
    You cant really tell on the front seals unless you pressure test the pump...There are no Vitons that i know of currently for the pumps...

  7. #7
    trofodotiki's Avatar
    Join Date
    Feb 2011
    Location
    Athens Greece
    Posts
    101
    +1
    1
    Should i just run it for say 3-4 hours, take it appart again and look for water?

  8. #8
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    If you look at the cone there is some open space on the outside. I bet that is where the water came from I remember the first time I pulled mine it surprised me... Did the grease look ok ? Probably not an issue.

  9. #9
    trofodotiki's Avatar
    Join Date
    Feb 2011
    Location
    Athens Greece
    Posts
    101
    +1
    1
    Quote Originally Posted by mrbtd View Post
    If you look at the cone there is some open space on the outside. I bet that is where the water came from I remember the first time I pulled mine it surprised me... Did the grease look ok ? Probably not an issue.
    Well, the grease looked black-grey, which i think means it got mixed with water,,,not sure if it was simply age and heat. You mean the part where is seals against the O-rings?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water in the jet pump :( Questions
    By Turbofab in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-18-2013, 12:36 PM
  2. Water in the pump cone and bearings...now what???
    By RXP-REX in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-23-2007, 07:36 PM
  3. Water in the cone fixed
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-03-2006, 02:07 PM
  4. RXP Alot of Water in the hull HELP
    By Drake in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-25-2005, 02:21 PM
  5. How much water in the hull is "normal"?
    By Pee2xUSee in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-20-2005, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •