Results 1 to 10 of 10
  1. #1

    No Clutch Washers in Supercharger?? Ummm

    Hey All...New to SeaDoo ownership and to the forum. Learned a ton already just from searching so thanks to everyone.

    So I read about the SC ceramic washers and after only having the skis out once I am changing them out with Rivas. A 2005 RXP (30hours) and 2004 GTX (24hours). I am stumped now that I have the RXP SC all apart. The prior owner did nothing with the SCs on either ski. There are no clutch washers that I can see!!. Here is a pic of all that was on the shaft. Upon doing research is looks as if the spring washers are done and I need to do a complete rebuild?http://www.greenhulk.net/forums/show...harger-failure My assumption is the ceramics are GONE which helped the spring washers to go. SO thinking the worst...the ceramics disintegrated and maybe luckily the engine isnt trashed? It ran perfect for the hour I had it out. Whats the best way to check if they are somewhere in the engine? Anyone else come across the surprise of no clutch washers?

    Thanks in advance for the input. While waiting for feedback I am going to go tear the GTX apart and see what surprise is awaiting me.

    [/IMG]


  2. #2
    Fastest in my cove sfackett0's Avatar
    Join Date
    Aug 2007
    Location
    Sparrows Point, MD (near the Key Bridge)
    Posts
    1,000
    +1
    22
    pull the front screen and look for washer bits would be the first thing I'd do. If present then it looks like your going to have to pull the engine and flush it out. Also Id rebuild that charger too, better to start off on the right foot.

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    You say it ran perfect. What rpm's did you see?

    Oh, and welcome to the forum.

  4. #4
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    No way it ran perfect bro. Bet your rpms were way low.

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by Ocman View Post
    No way it ran perfect bro. Bet your rpms were way low.
    I am thinking he only saw about 6000. lol

  6. #6
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    If that lol. I can't even believe it started up, with all that missing.

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by Sturm215 View Post
    If that lol. I can't even believe it started up, with all that missing.
    Oh, they will start and run. But it is just a ticking time bomb.

  8. #8
    Just pulled the '04...looks like it is supposed to be with tight spring washers and ceramic washers. Guess I will be pulling the RXP engine. Welcome to Supercharged SeaDoos lol. From my lack of experience on 4-stroke skis it seemed to run great. Didnt notice max RPMs...Two of us ran 66mph across the lake. But you guys are probably right that it really wasnt. Thanks for the input. Flushing the engine doable myself?

    Thanks again!

  9. #9

    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    25
    sounds like the right sort of speed for the charger to be working on a stock ski. It hasn't dont something crazy like welded its self to the shaft? Either that or you'd have to assume you were hitting 66mph and the washers failed right at the end of the day..

  10. #10

    Join Date
    Jan 2007
    Location
    Milwaukee, Wisconsin, United States
    Posts
    773
    +1
    1
    Check engine for spare parts. You may have an enginnne issues. I have seed change entire engines when under warranty .
    You don't want to see it happen when you are far away from help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lets hope no clutch washers fail on this one! :)
    By GasResearch-VT.SE in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 03-09-2013, 07:03 AM
  2. Replies: 12
    Last Post: 01-02-2010, 12:34 PM
  3. Any difference in these clutch washers?
    By bryanw80 in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-01-2009, 12:01 AM
  4. 06-07 riva supercharger metal clutch washers for sale
    By H2HO in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 05-10-2009, 03:05 PM
  5. OEM Supercharger clutch washer failure on my RXT-X
    By heckie in forum 4-Tec Performance
    Replies: 95
    Last Post: 03-25-2009, 02:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •