Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    RXT Is taking on water?

    A friend of mine have asked me to take a look at his ski because hi is taking on water, it is a 2009 RXT Is with 58 hours on it

    He explained to me that if he is just letting it idle or running slow he is not taking on water but if he is turning and getting into the throttle it cavitates badly and he i taking on a lot of water.
    He also said when draining the ski the water coming out is hot.

    I thought i would ask here before i tear into it: what do you guys think is the problem?

    Regards from Norway


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Carbon seal is bad.......

  3. #3
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    do a search,another member said it was leaking at his brake mechanism thingy by the pump (sorry i don't have one)....the bolts had loosened,search it...

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by Snoman View Post
    Carbon seal is bad.......
    +1

    If its only doing it under acceleration.

  5. #5
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Carbon seal week! lol

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by sea-one View Post
    Carbon seal week! lol
    Yes, that and props.

  7. #7
    skiskeet's Avatar
    Join Date
    May 2010
    Location
    union nj
    Posts
    47
    agree with snoman prob the carbon seal

  8. #8
    Gomer Pyle starter99's Avatar
    Join Date
    Sep 2009
    Location
    GA
    Posts
    642
    +1
    54
    i just had my carbon ringre place .motor out of Alignment carbon ring looked like a egg
    Alignment was out a little

  9. #9
    Thank you for your replies, i have started to tear down and found the rear bolt on the right side holding the pump housing to the ride plate missing. All the other bolts where tight, can this be the cause it is taking on water or would it mess up the alignment so the carbon seal is going bad?

  10. #10
    Gomer Pyle starter99's Avatar
    Join Date
    Sep 2009
    Location
    GA
    Posts
    642
    +1
    54
    check alignment install new carbon seal u be goo to go

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2009 RXT iS taking on water
    By driveumhard in forum 4-Tec Performance
    Replies: 3
    Last Post: 01-01-2011, 10:48 AM
  2. my 780 slt is taking on water
    By hawg in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-19-2009, 05:50 PM
  3. So this guy's GPR is taking on water
    By Pistonwash in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 04-17-2009, 06:46 PM
  4. RXT-X taking on water after mods !
    By Alfy in forum 4-Tec Performance
    Replies: 30
    Last Post: 09-04-2008, 03:03 PM
  5. 97 spx is taking on water. Any suggestions???
    By dleary46 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-02-2008, 10:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •