Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38
  1. #1
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005

    AAAARRRRGGGGHHHH X charger and 42# injectors install rough running

    I installed the X Charger and injectors I tried to stat it and its running rough as heck. Does it need to learn the new O2 settings like a GM car, or should it have taken right off? I will know more tomorrow as I am charging the battery on the trickle charger tonight.


  2. #2
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    Quote Originally Posted by race24x View Post
    I installed the X Charger and injectors I tried to stat it and its running rough as heck. Does it need to learn the new O2 settings like a GM car, or should it have taken right off? I will know more tomorrow as I am charging the battery on the trickle charger tonight.
    are you talking about idle, on the trailer?

    When I had an internal IC, X charger, and 42's, the idle was pretty rough on the trailer, depending on temp and other variables.

    Also, might be a good time to change spark plugs too.

  3. #3
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24
    From what I was told u need an air fuel reg to run this setup. Or a special plug. Can't remember what kinda

  4. #4
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by alex_baker202 View Post
    From what I was told u need an air fuel reg to run this setup. Or a special plug. Can't remember what kinda
    No you don't. You need a regulator (RRPFR) when you add an external IC. X CHARGER and 42's are ok. Fresh plugs are a no brainer and should have been changed.

  5. #5
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    I started the ski before I changed anything and it ran fine on the trailer. I put the x Charger and injectors in and now it will idle for about 5 seconds and shut off. If I catch it before it stalls and rev it a little bit it will run but backfires through the exhaust and will not run right. I cant even get it to run long enough to turn the hose on. I am thinking of putting the stock injectors back in to see if that is the issue. I get a P1544 if I try to many times I think that is a hot exhaust warning because I havent turned the hose on yet.

  6. #6
    pass1's Avatar
    Join Date
    Apr 2009
    Location
    Gatineau, Canada
    Posts
    423
    +1
    5
    I think p1544 is the exhaust code (dont have my manual with me), did you forgot to plug the sensor back in cause 5 sec of running without water will NOT cause the code to come up.

  7. #7
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    did u make sure all injectors are spraying?

  8. #8
    WBoulton's Avatar
    Join Date
    Mar 2010
    Location
    doylestown PA, sea isle city, nj
    Posts
    569
    +1
    1
    Check the injectors to make sure their all plugged into the right spots. Kinda sounds like the firing order is off.

  9. #9
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Sounds like your e-bay injectors are not what there supposed to be. Do you have a link to the injector specs?

  10. #10
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    Definatly try stock injectors to root out the problem. Just don't go riding on the lake with them, as i'm sure you will be pretty lean.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts X Charger and 42 Injectors
    By Polarisracer166 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 07-23-2012, 12:01 PM
  2. FS S3 Super Charger and #42 injectors
    By h2jim in forum Sea Doo Classifieds
    Replies: 9
    Last Post: 06-06-2011, 09:43 PM
  3. WTB x charger and 42 injectors
    By elbondspwc in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-30-2010, 05:22 PM
  4. Replies: 1
    Last Post: 04-01-2010, 02:01 AM
  5. Replies: 1
    Last Post: 08-22-2009, 12:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •