Results 1 to 9 of 9
  1. #1

    Angry problem with rxp-2005

    Hi! i just bought a rxp-2005 and i get oil warning light when i run it, i understand that it is a problem with the oil pressure switch on this modells...how can i get faulty codes with no set or mode button???? do i have to connect diagnostic tool if i dont have that button??


  2. #2
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    I'd first check the basics to make sure enough oil is in it. At least half way on dipstick.

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    Quote Originally Posted by 7947andre View Post
    Hi! i just bought a rxp-2005 and i get oil warning light when i run it, i understand that it is a problem with the oil pressure switch on this modells...how can i get faulty codes with no set or mode button???? do i have to connect diagnostic tool if i dont have that button??
    A 2005 RXP has the mode and set buttons. Fault codes will come up after you hit "set" 5 times. The oil warning light is most likely a low oil level, faulty oil pressure switch, or possibly a TOPS valve malfunction.

  4. #4
    The oillevel is ok! it is very strange noooo set or mode buttons!!!!???? it is suppose to be next to the vts and start/stop button but nothing????? any idea

  5. #5
    I have located one sensor under oilfilter but where are the other one??

  6. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    There's a blue one under the intake manifold, and the other one
    Is on the front of the oil separator below the stock intercooler location
    With one wire going to it.

    The 05' has the mode / set button on it stock. Someone took it off??

  7. #7
    Ok! Thanks for info it is very strange?? i disconnected the lid where the vts button are and there are no wires there exept to the start/stop and vts.... i vrote wrong year it is a 2006 modell but i guess it is stock in this modell to?? i bought it here in sweden but the ski is imported from the us....

  8. #8
    i found another 2006 rxp here on a site like your craigslist that had no set or mode buttons...?

  9. #9
    sorry i noticed that 2006 not have this buttons......can i check faulty codes any other way or do they appear when it is something wrong...??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem With 2005 RXP
    By Codemaster124 in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-06-2014, 11:00 AM
  2. Problems with RXP
    By SteffenS in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-10-2007, 09:09 AM
  3. Replies: 9
    Last Post: 04-19-2006, 07:06 PM
  4. Help, having problems with my 2005 RXT, low hours
    By 05rxt in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-10-2006, 11:24 PM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •