Results 1 to 3 of 3

Thread: knock sensor

  1. #1

    Join Date
    May 2011
    Location
    punta gorda fl
    Posts
    29

    knock sensor

    took the ski out today and the knock sensor code comes on after i just put a new one in like 3 months ago and ran fine the past 10 times iv taken it out. it only goes on if i get in the throttle alot. any ideas?


  2. #2
    blackvr's Avatar
    Join Date
    May 2007
    Location
    west palm beach
    Posts
    520
    +1
    70
    knock sensors rarely go bad. either your block is dirty behind the sensor or its not torqued correctly. had that issue with mine once. cleaned both surfaces with sand paper and retorqued. hope that helps

  3. #3

    Join Date
    May 2011
    Location
    punta gorda fl
    Posts
    29
    thanks il try that

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How To: Install RR ECU after the knock sensor update 04 RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 15
    Last Post: 06-14-2008, 12:13 PM
  2. knock sensor going bad?
    By Green Hulk in forum 4-Tec Performance
    Replies: 49
    Last Post: 04-23-2008, 04:30 PM
  3. Knock Sensor update piggy back harness???
    By Pale Rider in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-16-2006, 08:36 PM
  4. Knock Sensor
    By meeper in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-08-2005, 10:43 AM
  5. Latch & Knock Sensor Recall
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-01-2005, 04:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •