Page 1 of 7 1 2 3 ... LastLast
Results 1 to 10 of 63
  1. #1
    Wheels-X's Avatar
    Join Date
    Apr 2011
    Location
    York, PA
    Posts
    45

    It Lives...again.

    Well fellas I finally got my ski running after my motor destroyed itself in June of last year. With plenty of time, planning, and of course money I am nearly ready to set it back in the water and test the thing out. I had a pretty fast ski last year, or so I thought but I should have an absolute monster this year. My mods are listed in my sig.

    I have mocked up a pressure relief system that I hope to be effective and if it keeps me from stuffing I intend to do a full write up on it. It is very cost effective and easy in my opinion with a little mechanical background.

    I'm interested to see people's opinions on my build...any problems you foresee me running into, and questions you might have on how or why I did something I did...things like that. I'm always open to comments and criticism. I want it done right and I'll do what it takes to get there.

    I'd like to thank Jerry (Green Hulk) especially for all his time with my orders, emails, questions, dealing with Riva for me (motor took so long lol) etc. This forum has definitely taught me plenty as well. Thanks to JP1300R and Macdaddy_rxp for their help with a few things. Ocman, Duke, Snoman, and a few others on here I have to thank you even though I never dealt directly with you guys...you just have a shit ton of info in these forums lol.

    So here's my 2 videos from my rainy start up today:





    I'll def get some better pics and vids when it's buttoned up and clean and get some good weather. That molten orange paint looks so sexy in the sun


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Looks great.... Why are you flushing your system from within the hull? Just noticed that.

  3. #3
    Wheels-X's Avatar
    Join Date
    Apr 2011
    Location
    York, PA
    Posts
    45
    Quote Originally Posted by MSRXP View Post
    Looks great.... Why are you flushing your system from within the hull? Just noticed that.
    The riva open loop has a quick lock style hose hookup in the hull. I have it tucked in behind my groco strainer and secured to the hull. Didn't leak a drop.

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Good luck with the maiden voyage..

  5. #5
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,224
    +1
    53
    any pics of how you installed your gauges?

  6. #6
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Looks great!!! Should be another fast PX.

  7. #7
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Looks Great!!!! I Like the Red!!!How did, or what did you use to cut into the mirrors to get your gauges in them???i have an AFR gauge i want to do the same thing to.....

  8. #8
    thats a clean looking machine ........nice job

  9. #9
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    +1 on that color...

  10. #10
    Hondapro210's Avatar
    Join Date
    Apr 2011
    Location
    San Antonio, TX
    Posts
    166
    Quote Originally Posted by krouchchocolate View Post
    any pics of how you installed your gauges?
    That's what I was thinking!! Looks sweet....

Page 1 of 7 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. piston wash - does it shrink again when it gets way too rich?
    By sleeper_dave in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 09-28-2010, 06:09 PM
  2. world record attempt on a PWC - Track it live
    By Green Hulk in forum Open Discussion
    Replies: 10
    Last Post: 10-06-2009, 07:24 PM
  3. I want it shiny again
    By novaboy in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 04-17-2009, 01:28 PM
  4. Replies: 4
    Last Post: 10-13-2008, 08:51 AM
  5. Well It happened again to me!
    By 2fast4u in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 05-06-2008, 03:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •