Results 1 to 3 of 3
  1. #1
    goinbroke09's Avatar
    Join Date
    Jan 2010
    Location
    etown MD
    Posts
    17

    Hydrolocked!! Please help

    i know my crank seals are to blame but i cant seem to get all of the oil out of the rear cylinder. i know this is a common problem but i just want to get it started. any advice? its a 96 xp.


  2. #2
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Private message sent

  3. #3
    goinbroke09's Avatar
    Join Date
    Jan 2010
    Location
    etown MD
    Posts
    17
    thanks so much i got it started today and ran it for a while on the hose. Now i think i have a new problem. the MAG cylinder is hot to the touch after running whereas the PTO side feels fine. any insight?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM
  2. 4-Seater jetski with Mercury Jet Propulsion... please help
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-19-2005, 02:18 PM
  3. Please Help!!!!!!!!
    By RXP215 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-15-2005, 10:09 AM
  4. CHEWED UP SOME ROPE TODAY PLEASE HELP
    By PAINKILLER in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-07-2005, 02:14 PM
  5. PLEASE HELP MUSIC DOWNLOADING
    By CRAZEDRXP in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-05-2005, 09:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •