Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 79
  1. #1
    If I only had a brain..... elad's Avatar
    Join Date
    May 2011
    Location
    Western New York
    Posts
    43

    1994 SLT 750 "rattle"

    I just purchased this ski and it seems to have quite a rattle in it. I've read they make some rattling sounds but it just seems that this is excessive. Where is the first place to look and what do I check for?
    Attached Files Attached Files


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Welcome

    The rattle is either in the jet pump/driveline or the engine. When you have the jet pump removed to can run the engine and see if the rattle is still present.

    You have lots of work to do to thoroughly check that machine over and do the recommended maintenance and upgrades. Click my signature links below.

    Start by checking engine compression

  3. #3
    If I only had a brain..... elad's Avatar
    Join Date
    May 2011
    Location
    Western New York
    Posts
    43
    Thanks K447. I assume I start with the 4 long bolts on the outside of the ski. Do you have any tricks or do I need any special tools to get the jet pump out?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by elad View Post
    Thanks K447. I assume I start with the 4 long bolts on the outside of the ski. Do you have any tricks or do I need any special tools to get the jet pump out?
    Do have a look through my signature links below. There is an entire Jet Pump section complete with photos and video segments

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    K stop closing threads..

  6. #6
    If I only had a brain..... elad's Avatar
    Join Date
    May 2011
    Location
    Western New York
    Posts
    43
    I got the jet pump off the ski and ran it and it sounds okay now. Should you be able to hold on to the stator and spin the impeller with your finger or should there be a little resistance. There dosen't seem to be any slop in the bearings of the impeller.

    Could it be something as simple as no grease in the 2 fittings at the plastic shroud on the shaft because I have not found a needle attachment for my grease gun?

    I have attached a video and some photos.

    By the way K, your info on here and YouTube has been a HUGE help!! THANKS.

    http://www.flickr.com/photos/3426917...in/photostream






  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Did you also remove the drive shaft?

    The impeller bearings are greased, so there should be some resistance. It won't 'spin', but it should turn fairly easily, and more importantly, smoothly.

    I would remove the entire through-hull assembly (undo hose clamps and work it loose) and then examine it for internal wear or sloppy fit on the drive shaft. There are sleeve bushings inside which should fit closely on the drive shaft. I don't recall if the version used in 1994 is rebuild-able, but if not then good used ones are not expensive. Rebuild info can be found on my Jet Pump page.

    Have you checked compression yet? Want to make sure the engine itself isn't rattling because something is damaged inside...

    Some guys remove the needle grease fittings and install Zerk fittings. The only downside is that you must be careful to not snag anything (hoses, clothing, wires) on the spinning Zerk fittings - safety issue.

    Also check the drive splines on drive shaft, impeller and PTO coupler. Rounded or worn splines are not good.

  8. #8
    If I only had a brain..... elad's Avatar
    Join Date
    May 2011
    Location
    Western New York
    Posts
    43
    No I did not remove the drive shaft. I tried pulling on it an wiggling it but it did not come out right away so I left it. Is there a secret to getting it out?

    I have not checked compression yet.

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by elad View Post
    No I did not remove the drive shaft. I tried pulling on it an wiggling it but it did not come out right away so I left it. Is there a secret to getting it out?

    I have not checked compression yet.
    Drive shaft just pulls straight out. It can take some grunt, so don't fall over when it lets go

    Don't run the engine with just the drive shaft without the jet pump. The jet pump supports the end of the shaft, otherwise it will just flop around when the engine is running.

  10. #10
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    Welcome to the Hulk!

    "Polaris rattle" they all have it.. greasing everything quiets it down..but you'll still hear it out of the water.. not to worry. I have the 95 version of your ski.. read up on the updates, recommended upgrades to the fuel system, and carb rebuilding.. all are VERY important. remember, your have an older ski there. its not new.. take some time and read about your ski and get familiar with whats going on under that seat.

    learn what piston wash is, impellor clearence,engine pictures, where the ebox is, whats in it? that kinda thing.. you'll feel way beeter and more confident with knowing your ski.. your ski is a riot to be on.. take care of it and throw some cash at it and you'll have fun on it..

    might take 200.00 to get it all taken care of up to snuff.. Just ask. we'll help ya anyway we can..

Page 1 of 8 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 SLT 750 - unconnected red wire outside electrical box?
    By fnIrish in forum Polaris Open Discussion
    Replies: 14
    Last Post: 05-10-2011, 06:42 PM
  2. 1994 SLT 750 CDI replacement options
    By toddy256 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 03-25-2011, 12:35 AM
  3. 1994 SLT 750 for sale or part out OKLA.
    By kickr69 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-07-2010, 05:23 PM
  4. 1994 SLT 750 Polaris running to rich
    By tommy73 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 04-21-2009, 09:34 PM
  5. 1994 Slt 750 > Parts
    By mjlaforest in forum Polaris Classifieds
    Replies: 6
    Last Post: 09-02-2008, 02:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •