Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    2000 polaris genesis ficht we

    This jet ski will races when I first crank it up.then wants to flood the plugs


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Welcome to the Hulk

    Is this machine new to you? Has it ever worked properly?

    Throttle cable slack set correctly?

    Unplug the TPS sensor at the rear of the throttle body. Does it now start and idle correctly?

    What do you mean by 'flood the plugs'?

    Correct spark plugs installed? NGK PZFR6H only.

  3. #3
    Yes it did run fine.the plugs are new and correct.its turning tne plugs black and won't go over 4000 rpms

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    What changed? When did it change?

    Any warning message on the MFI display?
    Check Engine, HOT, Reverse?

  5. #5
    I unplugged the tps and it wants to races away

  6. #6
    There are no warning s on the display

  7. #7
    yes the plugs are new and NGK PZFR6H

    The ski runs good at idle, when i give it gas it acts like it is flooding out.

    I can milk the throttle and it will start to clean up and then it losese power.

    I disconected the tps cencor and the engine will race.

    there are no codes comming up on the mfi.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Engine races when TPS is unplugged...

    EMM may need repair. If you send it to DFI Technologies they can test it and repair if needed.

    Do you have access to another EMM or TPS?

  9. #9
    no i dont. so i will start with the tps.

    thre is only 85 hrs on the machine, so i will start there.

    thanks.

    are there any other symtems that i should be looking for.

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by daddymac View Post
    ... are there any other symptoms that i should be looking for.
    Well, you can use a simple LED tool to read the trouble codes from the EMM.

    Note the codes, then clear the codes. Read codes again, and see if any are 'hard codes' that immediately return after clearing. Hard Codes are problems that are happening 'right now'.

    If no hard codes, then run the engine, then re-read the codes for any new codes.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Polaris Genesis Ficht
    By Macca in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 02-14-2013, 04:27 AM
  2. 2000 Polaris Genesis Ficht ...TOO SLOW. NEED MORE POWER... BUT HOW
    By blastedm3 in forum Polaris PWC Performance
    Replies: 24
    Last Post: 08-27-2012, 02:50 PM
  3. 2000 polaris genesis ficht we
    By daddymac in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-31-2011, 07:26 PM
  4. 2000 polaris genesis ficht codes 81 82 83
    By rspray in forum Polaris Open Discussion
    Replies: 11
    Last Post: 09-09-2010, 07:48 AM
  5. FS (2)2000 Polaris Genesis 1200 Ficht for Parts or complete
    By Vagaondracing103 in forum Polaris Classifieds
    Replies: 6
    Last Post: 11-04-2008, 04:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •