Results 1 to 9 of 9
  1. #1
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,224
    +1
    53

    Intercooler gasket in motor?

    I had just removed my stock intercooler, and noticed that the gasket on the end of the cooler was not there. It also wasn't in the intake manifold. Could there have been a chance it was sucked into the motor? My ski was running fine yesterday, until I had ingested a little water through my front air intake. Ran 8000 rpms majority of the day when it wasn't as choppy.

    I would assume that if the gasket was in the motor, wouldn't the ski run like shit?


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Not all have it. I think it was updated in 06

  3. #3
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,066
    +1
    790
    What year? The early models had a O-ring on each side and not the bigger rubber gaskets.
    DO you have a O-Ring on each side?

  4. #4
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,224
    +1
    53
    I have a 06 RXT ski. I have 1 of the rubber gaskets, but can't find the 2nd one at the end of the intercooler.

  5. #5
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Don't think there is one. Just the o-ring

  6. #6
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,224
    +1
    53
    I am looking at the microfiche on the OEM website, and it shows 2 rubber gaskets. The intercooler also has the imprint for a rubber gasket that is suppose to be there. This is frustrating!

  7. #7
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    my 04 has O rings,one green and one black..

  8. #8
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Take the intake manifold loose. Its not that big of a job. Not sure what year ski it was, but remember seeing a picture of a I/C gasket stuck into a intake port and valve on here before.

  9. #9
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,224
    +1
    53
    Quote Originally Posted by jp1300r View Post
    Take the intake manifold loose. Its not that big of a job. Not sure what year ski it was, but remember seeing a picture of a I/C gasket stuck into a intake port and valve on here before.
    yeah I removed the whole intake manifold off before. Didn't see anything in the manifold itself, or in the intake valves.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water in motor
    By billywilly in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-04-2007, 07:45 PM
  2. Part # for intercooler gasket
    By efizjb in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-03-2007, 05:36 PM
  3. Intercooler gains in speed
    By JimC in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-26-2007, 04:37 PM
  4. Water in motor
    By explude in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-18-2007, 07:56 PM
  5. intercooler questions (in the right section now)
    By canadaxp in forum 4-Tec Performance
    Replies: 14
    Last Post: 11-07-2006, 08:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •